DHT11 and Raspberry Pi

I have been following Turtorial on how to add a DHT11/22 on a Raspberry Pi to get the sensor to show up in Cayenne. I got all the way to the line where you edit the “cayenne_dht.plugin” using the command “init_args={“sensor”: 11, “pin”: 17}”, but when I run that command I get “bash: 11,: command not found”. I have tried to manually edit the .plugin file, but it is protected some way. I can always use pin 17 as is specified by default, but I just want to know what I am missing because it has to be something simple. Thanks.

can you share the entire error you are getting.

So I have been through the tutorial here and when I get to the second to last command to set the sensor type and GPIO pin that it is connected to this is the error I get in Terminal:

you need to edit the cayenne_dht.plugin file using sudo nano and change the init_args={"sensor": 11, "pin": 17}

I saw that in a previous post, found a short tutorial on nano and I was able to edit the file and added temp and humidity to the dashboard. Thanks for your help!

1 Like