Hi all,

Looking at moving my 2 x DS18B20 and 8 channel relay from my RPI 2 (works fine) to a stand alone ESP…
Have been chatting to Craig ( :slight_smile: ) on the basics of this…

I have one of the early ESP8266 boards, but I see there are many new versions since.

Would the ESP-12 be able to run the above devices; enough IO’s etc?

Whats the “best” ESP out there at the moment, processor, memory etc?

Looking to buy in the next few days…


I like the ESP-07s because of the external antenna connection. Having two antennas, the onboard chip one and the external maximizes range. It does have less IO though.

The ESP 12s have a micro strip antenna and a little more IO on that front edge.

I have Cayenne working with both.




So far the 12’s are working well for my application. My range is not such that I require additional signal range (all indoors with adequate coverage), but my I/O needs are pretty high. I’m running the same DS12B20’s with a relay board as well. :+1:


Doing some more testing over this weekend, was contemplating multiplexing…may not need it if I prioritize my needs better. But for the cost, I could always just add another esp.


Hi all,

@Ian @kreggly.

Thanks for the support!

Now bought a WEMOS D1 R2 ,

Cayenne OK
Just adding :

-#include " CayenneDefines.h "
-#include " BlynkSimpleEsp8266.h "
-#include " CayenneWiFiClient.h "

It worked!
( Unfortunately the Wemos reboots loop after 8 seconds )

Now I am with the famous problem of reset wdt

" Ets Jan 8 2013 rst cause : 2 mode boot: (3.6 )

load 0x4010f000 , len 1264, room 16
tail 0
chksum 0x42
CSUM 0x42
~ Ld "

I am following the github ESP8266 and testing some solutions , but so far I could not make my Wemos stay connected and operating with Cayenne .

Esp8266-12E Program wont run with Cayenne Library

Hi Jhonathan,

Can you show your full sketch as an attachment?

In the past, we’ve seen issues with other non Cayenne code cause this behavior.




Hi @kreggly,

For testing , I’m just running the Cayenne.

#include “CayenneDefines.h”
#include “BlynkSimpleEsp8266.h”
#include “CayenneWiFiClient.h”
#define CAYENNE_PRINT Serial

char token[] = "MyToken";
char ssid[] = "MySSID";
char password[] = "MyPass";
void setup()
  Cayenne.begin(token, ssid, password);
void loop()


Yeah, all I can think of is that your RTS or DTR are getting pulses on those lines. On that board, they use those lines to put the ESP into boot mode.

Maybe try 9600 for debug, or eliminate debug completely and see if the issue goes away.



Solved !

“eliminate debug completely”



Sweet. My guess is it is the speed causing the flow control lines to come into play. See if 9600 is working for you.




Serial Monitor at 9600 working.


Now, i will add DHT11, relays, and done…hehhehehe


Huh? You lost me there- “OPEN” a .h file?


Just follow my how to, @HighTech. You shouldn’t need to modify any header (.h) files. Ifnyou want to use.the mkt1000, you need to add a couple new .h files I created, but it is not good practice to modify the existing library files.




You beat me by a couple minutes lol. Yes you can ignore my post, @kreggly post is the one to follow.


I beat ya all with the video proof! :wink:


I’m happy as a hog in slop!
Let’s see if I can make a swarm of’em work! :slight_smile:

I figured (by brute trial and error) that
GPIO 4 is, in fact Pin 4 in setup configure.
I’ll need to configure GPIO 12, 13, 14 and 16
as inputs (pulled high by internal pullup resistor)
for the ALLIE!
Please, tell me that “inputs” can be pulled up via internal pullup resistors-

also, in setup/configure inputs,
I can’t see what “pins” GPIO 12, 13, 14 and 16 go to-
the configuration only gives me 0 - 13…
I’m kind of…trying to use them…

I use GPIO 12, 13, 14 and 16 output to relays.
I designed my “inputs” as GPIO 5, 4
(and 2 and 0 if using GPIO 2 and 0 is possible).

I’m having a ball!


I don’t know if you’re still in the community- but hey! I JUST got my Esp12-e design working. My NEXT step is to use either the SPI or 1Wire or I2C (whichever works on the Esp12-e), to use a GPIO I/O expander. THAT would give you all the I/O you could possibly need from one Esp12-e!


well- I got my ESP12e Quad Relay built-
problems with the I/O, though.
My relays are addressed usin GPIO 12, 13, 14 and 16.
The problem is- I can’t seem to address GPIO 13, 14, or 16.

I CAN access GPIO 12 (D12),
so I have (1) relay that actually works. :frowning:

The GPIO left pins ALL work- D0 (it works), D2, D4 and D5. I’m just…not using them. I suppose I could wirewrap them to GPIO 2,4 and 5

Help, please- drivers for the Esp12-e


Hi Bill,

Yeah, @bestes, this is a limitation I noticed the other day too. The I/O selection for Digital actuators only goes to 12.

The work around is to use virtual registers and use the GPIO write call in your CAYENNE_IN(VX) function to set your output state. Remember to preset the I/O direction in setup().