Getting ip


Is there a solution for this problem
When i in arduino upload is that answer the same in the serial monitor

mac adres ae etc
getting ip …

and waiting for hours
but it is asking
and askng

any help please


Can you please explain more detail. I cannot understand what is the problem?


thanks for the attention for my problem

The problem:
With my arduino it is not possible to upload a sketch
In earlier time it was possible The manner to upload is not changed, nor mine equipment.
While uploading is there always the same error!
The mac adres is all right but then

getting Ip…

and it stops
I cannot find the adressthat is needed -what that might be-.
(there is only the computer (with windows 10 )
question ::what adress is the arduino upload looking for ?


Okey, I will try to figure out the problem.

Can you see in the Device Manager, what is your COM port and in Arduino IDE -> TOOLS -> BOARD -> Select Your Board.

Then -> TOOLS -> Serial Port -> Select the Serial Port that corresponds with the port that arduino is found on your computer.


Again thanks for your help.
But that is not the solution
The sketch works stand alone
The usb port and the sreialport number are OK
but still.
The strange question is:

It was working well for some time, now it is over,
I believe that it is an internal quesion on mine PC . But where and what?
i am using a dynamis ip dress, but the static is even not working.



What type of connection are you using? Ex. Ethernet shield, ESP/WiFi shield, USB from windows host, etc? This can help narrow down where the issue is.


thanks again
Arduino genuinio uno
with ethernet shield w5100

but arduino met wifi en ethernetshield w5100 gives thecsame text
mac ae . enz
getting IP…



hello friends…
i am facing almost the same problem as above my details are as follows

board - arduino uno
shield – W5100

in my case i m uploading the sketch file ethernetshieldW5100 from the examples and then adding the token number to it. and then trying to upload. it works fine and sketch is uploaded nicely.
but my problem is , after uploading , the deshboad never comes , it says — “waiting for board to connect”…
when i check in serial monitor, as explained in guides on the site, it just shows the following

[60446] DHCP Failed!
[0] MAC: FE-A9-DB-9B-AC-A5
[1] Getting IP…
[60446] DHCP Failed!
[1] MAC: FE-A9-DB-9B-AC-A5
[1] Getting IP…
and so on…

this means it never connects to the net…

i don’t understand why…
if someone can suggest a solution for this
please help.
thanks in advance friends…


Do you have the Ethernet cable attached to a computer or are you plugged in to a switch/router?


i have tried both possibilities and the result is the same.

i am using a dynamic ip
(in earlier time gives DCHP troubles)



Do you have anything else plugged in to the same device, and are they working? At this point you either have a DHCP server problem (nothing should get an IP address) or you have an Ethernet shield hardware problem. Do you have another shield you can test with?


ok Adam
i have tried all your suggestions.
The result is negative.
I will try to re-install the whole installation.


What about to just manually add your MAC address of the PI with assigned IP number. Maybe just the router has trow it up for something ?


i just have attached a switch. 3 connectors are in switch , one is incoming broadband internet line, other one goes to my desktop and the 3rd one goes to ethernet shield. arduino is connected to same computer by usb cable.
i m still not getting any success solving the “DHCP failed” error and it never connects to the cloud. somewhere i red about connecting two, 100ohm resistors at the pins of RJ45 connector on ethernet shield. is that may be a possible hardware solution ? i haven’t tried yet … had any one try ? pls share the results.
but one thing is very sure that automatic ip allocation of DHCP arrangement fails to assign proper IP while it tryes to connect to the cloud. by some or some way.
pls post any updates.
thanks in advance .


Your problem sounds very strange and like a Network issue rather than anything else.I never tried or read about this with the resistor to the network port.


Some people have had success with the resistor, but that requires some soldering. Just be aware that if you bridge and connections you might fry the shield and or your Arduino as well. I would suggest getting another Ethernet shield to make sure you don’t have a hardware problem there.


it was an ordinary network error
installing the network again solved the problems
Thanks to everyone for theuir efforts.

greetings Dick


What do you mean by “installing the network” ?


installing from zero
one router - one pc - one arduino
getting an ip adress
and it was working as usual
So it was a networkfault