"No data available for this period" for graph, live data is shown


I am currently using Cayenne to monitor my The Things Network gateways. They are all based on a Raspberry Pi 3 and use a BME280 sensor that sends the temperature, humidity and barometric pressure via a Python script (using the package cayenne-mqtt) to the Cayenne server.
In the overview page I created two widgets for each data source: one showing the value and one showing the graph. However, the graph for the temperature works fine, but the graph of the humidity only shows “No data available for this period”. The value widget for the data sources seem to work fine.
When I switch the graph to “live” I can see the incoming values for each data source.
Do you have any idea, what’s happening here or what’s my mistake :slight_smile:?

No data:

Live view:

CU Tim


if you just creat widget , you must wait for some times.
However try to change the channel of humidity.
I don’t know why , sometime the channel you choose is not working properly.


I waited for more than one day… On the other Dashboard no graph shows up. Temperature is channel 1, pressure channel 2 and humidity channel 3. Hmm…


mmmh , try to change channel 3 to 10 or 20 for exemple.


Hi Same problem here, I have lost so many hours, and projects have started to be neglected. I have many issues that I feel may all be linked to this. Surely this is a bug, it is sooo frustrating that there is not more information available, I have been using Cayenne for around 6 months I had similar issues when I first used Cayenne, and again recently in the past few weeks (Since Arduino updated to MQTT), here is what I have found so far:
Many times you add a new channel to dashboard directly from what is auto detected by cayenne, at this point often you do not get the option to choose any other widget than value widget, at this point you might as well quit and start again - I read somewhere you should always use the first cayenne channel initiated widget to create the graph, then create any other widgets manually, however as option often doesn’t present itself…this is not possible.
This has happened on data types ‘Analog’, ‘Temperature’ and ‘Humidity, maybe more but for me this is what I have experienced.
I have also noticed that when setting data type at arduino to analog and then selecting this as data type on cayenne widget the widget disappears!
Many times when you delete widgets, they remain in the left Navigation tree for the device - impossible to delete!
I also have some widgets that display graphs but the timescales are wrong (Stuck at period in the past) the ‘no data for this period’ seems to be related to the graph updating its date period and the dates displayed are always wrong.
Some widget also will not allow you to get historical data from the chart pop up either (I assume similar issue)
I have done F5 etc so not an issue with cache etc.
Because I can only get part of maybe 30 widgets working I have not reset up any of my triggers and reluctant to do so at this point. I wanted to expand this out but it is just so frustrating, I have added and then deleted maybe 200 widgets 


I played with the channels and tried to reconfigure the widgets. Unfortunately nothing. Since this doesn’t seem to be reliable and I have already wasted enough time to figure it out I am moving to another service at the moment :frowning:.


@triemann @paulminize this time (In France) 9h55 data comes to be displayed in graph Widget !!!
Graph displayed Not only in LIVE !! :slight_smile:


Not got this chance for all channel … channel 27 :

  • open your Data Console Data%20Console
  • existing in LIVE Data%20console%20Existing%20in%20LIVE
  • but missing in “minutes” or more Data%20Console%20no%20result


All is ok for now !

And you ?


Hi all of my installed charts are now displaying data 23:40 Friday…

I still have issues initiating new channels, often i do not get the chart/graph option on the value widget.

As all my charts seems to work I cannot check/replicate your data view, I will check this if issue shows again.


I spoke too soon…

Both of these now around 23:57 UK data shown from yesterday…



@paulminize @triemann Another trick :
if you want more than 1 widget for the same Sensor on the Cayenne Dashboard

Ex : Graph Temperature + Gauge Temperature + Value Temperature

In your sketch : apply 1 channel for 1 widget !

  • channel 1 for Graph Temp
  • channel 2 for Gauge Temp
  • channel 2 for Value Temp

Then in Cayenne Dashboard you select what kind of widget you apply for the 3 new channel appeared.


Yes I think this was suggested earlier, it certainly seems like a handy little work around - HOWEVER…

I still have channels that initiate and I cant change the widget type.


Are you saying this should be fixed by using separate channels?


yes : don’t use 2 widget on the same channel !

My example :
i use channel 9 to display Graph Temp and channel 11 to display Value Temp

Arduino Sketch:
Cayenne.celsiusWrite(9, TxTemp); Cayenne.celsiusWrite(11, TxTemp);

Cross fingers, it’s working !

  • Delete all your widget based on channel 1 /!\ All your data should be deleted /!\
  • reset the Dashboard , Clear the cache (F5)
  • Wait for Cayenne display New Green Defaut widget
  • clic on “+” and choose your type of widget : Value - Gauge - Line Chart


Grrr. Cheers though I will do this asap.

Looks like I need to start from scratch again - Argh!!! I think I have added and removed 300+ widgets in past few weeks.

Really hopping this resolves all issues.


i hope to …


Okay, Almost there…

I deleted the lot and started from scratch with separate channels for widgets and all worked much better - all my charts are 100% fine :grinning:



Any update on this variable bug / issue ?
I have live data works.
But NOthing works other than live data on trends OR the data widget when selecting minutes / hours / date / custom etc.
Any pointers of things to check ?
I will create a fresh account / Pi 3 and see…
This is the same on a BYOD MQTT as well as Pi GPIOgeneric digital input pin I am test trending.
~ Andrew



Feel free to have a poke at this shared project link.


This was second attempt at streaming data into history but no go this time on a Pi 3 using BYOD. Installs and sets up like ‘poetry in motion’ but no history.

~ A