No data available for this period on graph

I’m having the problem that measured values will not be stored since about two days. On any widget, I can successfuly show the current value by clicking on “Live”. But switching to “m”, “h”, “d”. etc. will not give any graph. Instead, the message “No data available for this period” will be displayed. Only for a longer period like “w”, “1mo” etc. the graph is shown, but with an interpolated curve.

By hovering over the datapoints on “w” I could see that the values are stored on a very non-regular basis. Also, for the past two days, only two values were stored.

I have copied the REST GET call for a “m” graph and re-sent it again → It will only return me an empty JSON array. So there is really no data available and it’s not just a presentation issue.

I tried removing the whole device and re-inserted it with another device ID → still no luck.
The “live” view works on any widget, but no widget records any data…

What can I do?

Hi @Florianb,

Thanks for bringing this to our attention! We recently pushed some updated to our graph widget this past week.

What device are you using? Are you connecting through MQTT?



I am not using MQTT, I am using the standard arduino library and use the CAYENNE_OUT() callback functions to send data using Cayenne.virtualWrite(V0, value).

What is special is that about an hour after I posted the message yesterday it began to work again. However, just a few minutes ago it stopped working again :pensive:

Day view (Sidenote: Watch the weird Y-Scale):

Hour view:

Minute view:

Live view:


I am using a NodeMCU Arduino based device (ESP-12E).

The same problem.
I’m using Arduino Yun shield, web and iOs dashboard.

I virtualWrite data from sensors to virtual pins, using custom widgets connected to virtual pins to get data in the dashboard.

Hi @a.ivashin @Florianb,

Sorry for the late reply here. We have done many updates since this topic was created. How are things looking on your end?