How to connect Lattepanda board to Cayenne Website

Hi, I have a Lattepanda which has Windows 10 home installed. The Lattepanda board has a built in “Arduino Leonardo”, with a ethernet network card and wifi. I have trying to add this Lattepanda board to the website unsuccessfully. Tried to add it as an Arduino Leonardo, but none of the scripts seem to work for the board. Can someone provide advise of how can I connect the Lattepanda board?

I have successfully connected my LP to Cayenne. It is quite Simple.

  1. Install Cayenne Library in Arduino on the LP.

  2. In the Cayenne dashboard add new Microcontroller → Arduino Leonardo.

  3. Select USB Serial for connectivity (it is not WiFi).

  4. Load the Example from the Cayenne Library. In Arduino IDE go to: File → Examples → Cayenne → InternetConnections → SerialUSBConnection.

  5. Copy your Auth token from Cayenne into the sketch where indicated.

  6. Save the sketch and upload to the LP.

  7. Run the batch file to make the connection to Cayenne. (Think of the WiFi adapter on the LP being used as a serial modem for the Arduino Leonardo - this is the only real connectivity between the two even though they are all integrated onto a single board.

Batch file: cayenne-ser.bat


Make sure to read the ReadMe file for setting your COM port to the correct one. Leave the batch file running minimized and your LP will be connected to Cayenne.

1 Like

Also make sure you are running the latest version of the Arduino IDE and the Cayenne Library and it will work fine out of the box with built in library example.

Thanks a lot Tim_G_Tech, I was able to connect successfully to Cayenne portal. It was working just fine until the portal change. My relay controls are not reflecting the correct status, and after using the relays for a few times, I get disconnection from the serial port. The following continuous message appear on the command prompt of the serial connection:

SetCommMask() ERROR Invalid argument (22)

If I close the serial command prompt window (containing the serial connection) and run again the Cayenne-ser.bat batch file, it starts working again for sometime and then I get the same error. Have you seen this before? Not sure if it started after one of the Windows updates…

Sorry for just now responding to this!!! I have not run into this problem. Although I have not done a lot my Cayenne on my LP. Let me know if this is still an issue for you and I will see what I can do to help.