I cant select my raspberry pi to the devices


#1


#2

Hi @kabigtingallaine, welcome to the Cayenne Community

This is expected behavior as our Custom Widgets feature is Arduino only at the moment. We’re still developing this for Raspberry Pi and we’ll make an announcement here when that update is released. You should be able to pick any of the other widgets on that list, and you can use the ‘Bring your own thing’ API option if you need to pass data from widgets connected to a Pi that aren’t directly supported in lists of Sensors/Actuators in Cayenne.


#4

Is there an expected timeline for this to happen? It would be great if it’s happening soon. Otherwise I’ll need to find another way to do this.


#5

Welcome to cayenne!

You will need to use the MQTT API if you want to use the custom widgets. If you want to use the Pi agent then you need to use the digital output widget via add new>device/widget>actuators>generic>digital output.