Not able to create an actuator widget


For my project I had to create a new actuator widget for controlling actuators connected to the arduino from Cayenne but I’m unable to create an actuator widget. Even after entering all the required data the ‘Add Widget’ button is not highlighted and I’m unable to click it to create a new widget. Please help!



I can confirm I am having the same problem adding a button where the Add Widget button does not work



which arduino deice are you using??


Arduino Uno with ESP-1 which is connected to Cayenne using MQTT protocol


can you add a new device using “Bring Your Own Thing” and copy the MQTT credential into your code and then trying to add a custom button widget.


That is what I tried the whole time. I created a new device using “Bring your own thing” and first added sensors. Then I tried to add actuators but it didn’t work out


can you post the code and a screenshot of serial monitor and dashboard.


I’m not having any problem in sending sensor data to Cayenne from ESP-01. The problem is I’m not able to create an actuator widget.


yup i know but i cant seems to find the bug with your case. so need to see the code and dashboard screenshot. if can share it will be of great help.


@rlakshana36 @inertia2002 @shramik_salgaonkar this should be fixed now. Let us know if you are still running in to issues.



Thank you @bestes …I’m able to create a widget now