Redundant Widgets

Hi, I messed up my setup today, but managed to get things back on track, more or less, but I have a couple of minor issues that I cant seem to fathom out.
My temprature probe seems to be changing in the last couple of hours on the dashboard, but nothing is appearing on the D,H,M etc graphs ?

The other problem is when in the OVERVIEW window, on the lefthand side, its shows me what I have connected. This is where I messed up. I have added new widgets to get this working, but the original widgets are still there, and if I click on them, nothing happens, so they are not in use I guess, which is good. But how do I remove them. As I said if I click on them, nothing happens, the widget window doesnt open, so I can’t delete them in the normal way.Anyone know if there Is there any other way I can remove them. Im new to this and still on that very steep learning curve :slight_smile: Thanks…

are you sending the data with correct data types? if yes, try removing and re-adding the widget.

this is a bug and will fix it.

Thanks Shramik for your help and ok about the fix.
I’ve not done anything yet regarding the temperature probe because the CPU temperature has the same issue and I was wondering if there was a common fault between these two issues.
You get nothing on both the probe and the CPU sensors if you go into the H,M,WEEK etc readings. The only time you do get something is the LIVE view, that shows a grid and a dot in the centre of it.

the default pi widget like CPU, RAM, tempreature and other widget which are added on first boot, do not contain history. So they wont have data in H,M,D etc. The history data are there only for sensors you add to the cayenne pi agent.

Thanks for the reply, I’ll look at it later when I get back.
When you said correct data type, I’ve installed the probe twice and don’t recall seeing anything about a data type, it just worked. Sorry for the hassle, but could you please expand a little more on this . Thanks

i guess, you have raspberry pi added. The data type i referred above was for arduino device. So, can you delete and re-add the temperature sensor again.

Hi Shramik, thanks that did it and the probe is functioning perfectly, D,M, etc and for me that is going to be a very useful facility, thanks.

However, after fixing the probe, I have another problem and was wondering if you have had experiance of it.
Its only happened since I reinstalled the Temp Probe widget.

The devices I have to monitor things, my widgets, are very very slow to respond, and sometimes they don’t respond at all. My network has not changed in terms of signal quality, infact I have moved my MESH node nearer to the Pi that has Cayenne on it.
So at the moment I don’t trust it, shame as it was working great before I had the Temp Probe issue. Any Ideas what I could be. ?
Thanks

what do you mean by slow? the sensor data are published at an interval of 15seconds.

Hi, when I click on my app to turn a widget on, I click the toggle icon and as soon as I hit it the state changed.
Now what happens the circular timer appears and its just revolves for maybe 30 seconds ? And sometimes it has changed state and sometimes not. Incidentally, When made this project I stuck in led, so I could turn it on in the box that I made for the project, so that if there were a problem at night, I could turn this on to light up the stuff I had done. I also use this as a test device. So I have deleted it. I tried to renistall it and its saying Command line timed out. Not sure if this helps but I though I should mention it.
Its not the sensor Shrimik, just the “actuators” if you want to put it this way. And the same thing happens if I use my Phone app or via a web page on my desktop ?

let me check what the issue is.

Hi Shramik,
Not sure if you have tweaked anything at your end, but it’s all working fine at the moment at this end.

I knew this would happen. The temperature readings don’t seem to make sense again. I don’t get anything on the live H &M tags and I get these, which don’t seem to make sense on the D & W tabs

Sorry if I have doubled posted. But the temperature readings are not making sense again . I don’t get any readings on the Live, M & H tabs, but I did earlier and it was all making sense.

Hope you can help. Thanks

Hi, I checked the temprature agsin just now , which is several hours since my last posting and was getting the same identical readings.

So my guess was it’s just not working, so I deleted it. I have reinstalled it, and it was asking for a one wire slave address. To make it accept the sensor, I just put Pi in there as the tutorial didn’t say what you have to do. I went back to the overview page expecting a green shaded box showing the sensor , where I then just then “add” it to the overview board, but that hasn’t appeared, it just showed the sensor like the others, in a grey box but not showing any temperature. Just a dash and no data at all in the D,M,LIVE, tabs etc. Hope you might have some suggestions as to the fault , thanks Shramik, sorry for the hassle

Hi, I took a screenshot of pin four. It’s connected, but as I’m new to pi’s, I would have thought I should see the GPIO for pin 4 populated with something, but it’s not. Maybe I need to try another probe.
It’s hanging in the pond, if the seal has broken and water has got in there, could this be the problem?
But if this helps, there is no data for the CPU temperature either

Thanks .

check if your sensor is not damaged and then try again adding a new temp widget.

Hi Shramik, no problem, I have a spare but not sure I can do it today. Just so I know, would I or should I see a graph for the CPU, RAM, STORAGE etc?

no, these data do not have history data stored hence there are no graphs for this widget

Thanks Sharimik

1 Like

Hi Shramik
Changed the sensor it now works. Thanks
HOWEVER, can you believe it.
Since sorting the temp sensor, another problem has cropped up.
When I activate two of my four relays on the Cayenne app on my smartphone, the toggle switch icon turns from off to on then a red warning sign comes up and says “sensor command fail”
Do you think this is a problem with the relay or the pi or the connection from the pi to the relay board , or maybe a programme bug?