Relay switches dont work


#1

again hello
I have a problem with the relay switches they can no longer be addressed via cayenne.what could be the reason? i updated my pi via sudo apt-get could that be the reason?


#2

What do you mean they can’t be addressed? Cayenne is just sending a high or low signal to the designated pin on the pi. The low voltage pin is then switching the relay.

So if the relay stopped working there are two probable causes:

  1. The relay is not wired to the correct pin and therefore isn’t getting a signal from the pi. Check your wiring and check that your trigger is pointing at the correct pin.
  2. The pin is no longer being switched by Cayenne. Go into the GPIO dashboard and see if you can manually switch that pin high/low and that it’s correctly designated as an output.

#3

hi mdturner710.
thank you for your fast answer.
my relay is correctly wired, i know that because i can adress the pins via putty.
the only differnt is when i start up the raspberry the relay only shines light red.
i have to do the command “gpio export 26 out” then the red lights are shining bright red on the relay. if i read out the gpio then it shows 0.
i think i did somthing wrong with the bootup because befor the udating, the relay was clicking one time when i power up the pi.
also when i try to change the setting of i2C and aggree to reboot this setting will not stay. it is always to the off position. mayby you have an idea what i schould do.

best wishes from germany


#4

hi mdturner710
i solved the problem. Downgraded the Kernel. now it works fine,

thanks :slight_smile: