Relay unreachable


#1
  • Device & model you are using: RPi 2

  • What dashboard are you using: Web, Android

  • Please describe the bug / issue as detailed as possible:

Hello all,
today i find out that my two relays are unreachable:

I checked physically the box where are RPi 2 and the relay, the diodes on the relay are shining, so i dont know what is wrong, when i didnt do anything. can i test the relay somehow manually trough terminal?

here is also some output that could help you:

thanks for any help


#2

I also find out that my relays disapeared from android app…


#3

mmm, it looks like that something is wrong with myDevices app on my reaspberry


#4

If I remember correctly the conversation failed message is not a problem. For the widgets can you try to delete them and re-add to see if that works? I’m not sure why they would have entered that state to begin with though. You may have to click reset dashboard for them to go away.


#5

@adam - thanks for quick reply, I reset the whole view, created again the widgets, without success. Now i checked also settings, and all is disabled:

when i try to enable it, i will receive a message that the pi will be rebooted and nothing. i go to Overview and back to configuration menu, and all is still disabled.

i think something went wrong with last update for raspbian, because when i check raspi-config, there are some new options in interfacing option:


#6

I would rely on whatever raspi-config shows for those settings to be the true setting, since that settings page is known to be a bit buggy with regard to maintaining the correct state of the interface toggles.


#7

alright, @rsiegel pls do you have any suggestions? coz it looks that I2C is disabled


#8

Can you turn it on from within raspi-config?


#9

no, without success, also no change from web gui (also no error message on web gui)


#10

I’m sorry, I’m a little confused. What message to do you see differently from this flow when changing it in raspi-config?


#11

this i see, i tried it like this, but no change when i enable it, the relays are still unreachable in the webgui, and also the I2C slider is grey


#12

I see, I’d jumped into the middle of the conversation and didn’t consider why you were trying to toggle I2C. I would not worry about the Grey slider in Cayenne as that page often has state issues – if raspi-config says that it is enabled, then I trust that it likely is.

Do you mind sharing your login/password via private message so I can see if this reproduces on my end and investigate a bit? Do you mind if I re-create the widgets myself? I won’t actually click them to activate any relays.


#13

you should have it now, please let me know if you will find something, thx


#14

@Mio

Thanks much for your patience, I had a chance to look at your account / Pi and I think I see what the issue is.

Your Pi is running the 4.9 Linux kernel, and webiopi (which is a software we use to control/monitor the GPIO pins on Raspberry Pi) only works on the 4.4 kernel that’s part of stock Raspbian Jessie currently.

You can see your kernel version by running the command uname -a on your pi.

We are planning to update webiopi (we actually hired the developer at our company :slight_smile: ), so when Jessie moves to something newer than 4.4 we’ll be there to support it.

In the meantime, if you don’t have specific need for the 4.9 kernel, you can downgrade to 4.4 or do a fresh Jessie install, which should include 4.4. Either way I suspect you’ll have much better luck creating this widget without the ‘Unreachable’ state.


#15

@rsiegel - thanks for quick solution, so i downgraded my kernel:

 pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.9.24-v7+ #993 SMP Wed Apr 26 18:01:23 BST 2017 armv7l GNU/Linux
pi@raspberrypi:~ $ sudo rpi-update 52241088c1da59a359110d39c1875cda56496764
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 12762  100 12762    0     0  33569      0 --:--:-- --:--:-- --:--:-- 33584
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** We're running for the first time
 *** Backing up files (this will take a few minutes)
 *** Backing up firmware
 *** Backing up modules 4.9.24-v7+
This update bumps to rpi-4.4.y linux tree
Be aware there could be compatibility issues with some drivers
Discussion here:
https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=144087
##############################################################
 *** Downloading specific firmware revision (this will take a few minutes)
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   168    0   168    0     0    303      0 --:--:-- --:--:-- --:--:--   304
100 52.3M    0 52.3M    0     0   969k      0 --:--:--  0:00:55 --:--:--  274k
 *** Updating firmware
 *** Updating kernel modules
 *** depmod 4.4.50+
 *** depmod 4.4.50-v7+
 *** Updating VideoCore libraries
 *** Using HardFP libraries
 *** Updating SDK
 *** Running ldconfig
 *** Storing current firmware revision
 *** Deleting downloaded files
 *** Syncing changes to disk
 *** If no errors appeared, your firmware was successfully updated to 52241088c1da59a359110d39c1875cda56496764
 *** A reboot is needed to activate the new firmware
pi@raspberrypi:~ $ sudo reboot
login as: pi
pi@192.168.1.186's password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri May  5 06:59:41 2017

SSH is enabled and the default password for the 'pi' user has not been changed.
This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux

i will test the connection switches between android app and web, then i will let you know

thanks for your help

Edit: pls do I need to reinstall also my android app?


#16

Just saw your edit. No, there should be no need to reinstall the Android app. The issue is with a component of the Pi software that interacts with the GPIO pins, so the kernel change should be enough. Here’s hoping it goes well for you.


#17

so far everything is working ok, thanks again for help

i have another question, so from now i should not update my raspberry pi?


#18

Correct, the agent will auto update


#19

@Mio

Regarding updating your Pi outside of the Cayenne agent auto-update that @adam mentioned, it should be fine to run apt-get update and apt-get upgrade, I would just avoid explicitly running rpi-update until we’ve added 4.9 support, since it appears that that will grab the new kernel.

If this post is to be trusted, then rpi-update is deprecated anyway and the Kernel update will come via sudo apt-get upgrade when the maintainers of Raspbian have updated it in the stock release.


#20

@mio,

I just wanted to bump this thread to note that we’ve now updated our Pi agent to support the 4.9 kernel (it still supports 4.4 as well). The update was automatic in the background so there is nothing you need to do on your end. Feel free to use rpi-update to move forward to the 4.9 kernel at this point if you’d like!