Scheduled events not triggering action

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)
    Arduino (ESP12E)

  • What dashboard are you using? (Web, iOS, Android)
    Android & Web

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!

Hello - I had a relay set up with a schedule, which was working perfectly last week. It seems that some time between last week and now the scheduling has stopped working. I have removed and re-added the device, and I am still having the same problem.

I have tried all types of schedule to turn on/off the relay. I receive SMSs stating that the schedule has been triggered, but the relay doesn’t activate. The relay does activate when I press the button widget that I created. It seems like the schedule is working, but not sending the signal to activate the relay.

Like I said, this is strange, as everything was working fine a week ago.

Hi @beeng and welcome to the Cayenne community.

I apologize for making you spin your wheels, We did a major backend update last week and this appears to have broken Arduino Scheduler Events. We’re making a change in today should fix this bug.

I’ll update here as soon as the fix is in place so you can try again.

Thanks for the info. I deleted all my schedules and tried a new one today - it seems to be working so far. I’ll update if it breaks :slight_smile:

Thanks for letting me know. In the general case the fix I mentioned above is indeed in place.

My Schaduled events which is supposed to run 26 minutes ago, do not run. My experience is that schedules is sometimes work and sometimes it is not working. It is more reliable on Raspberry Pi than ardiuno, especially on arduino with wifi is the worse.

Is there still a problem with the custom/hourly repeating scheduled events? My schedule ran the first time, but doesn’t seem to be repeating correctly.

Edit: There’s something strange going on for sure… My “ON” schedules run fine, but none of my “OFF” schedules are running.

There is definitely an issue with Arduino scheduling still, it seems to revolve around when both of the events are created. In my case it’s the same, if I make an led ON and led OFF scheduled events, the 1st will run but the 2nd won’t. But an OFF event will run if it is created after the ON event runs. I know, not super useful in that state. :confused:

We have this as a hot issue that developers are investigating currently and I’ll update as soon as I have more information.

Thanks. That would explain why it appeared to work at first… I would set the scheduled event to some time in the near future so that I could see if would run, then created the OFF event.