Event stop working

Hello ,

I made an IOT FARM and i scheduled an event to turn off/on the light during the day . Everything was working properly but since 2 days the light doesn’t turn on/off

I can activate the light manually with no problem.

i tryed to create a new event but same problem

I also tryed to reset the arduino

I am using arduino uno with W5100 shield

Hi @flammeur,

Once we get this issue sorted out, I’d love if you shared your project as inspiration for the rest of the community. We recently had a project contest and IoT Chilibot won the contest, your project sounds similar since it is IoT Farm.

Okay, back to this issue. There are a couple small bugs with Scheduling feature that we found, and are pushing fixes soon. Can you tell us what exactly the schedule is that is not working anymore. Screenshot might be easiest…

Thank you!


i have the same trouble, in my pallet heat treatment chamber.

Can you post an image of the event that is not happening? This will enable us to test and fix.

Thank you!


it was working great untill yesterday, btw what a nice iot proyect builder !!!

thank for your help.

1 Like

here we go for mine thanks for the help

Are your events still not running?


Mine too are not working (weeks now), I have contacted rsiegel about it.
Seems, for me at least, the events have stopped working right about the time you released the MQTT API.
My setup is a raspberry pi 2 with a usb connected arduino nano (serial interface). I can manually use GPIO ports of arduino, but schedule events, although I get an email notification, are not working.


Any update on this ?

We plan to release some scheduling fixes today actually, within next 5 hours. Hopefully the release goes smoothly. Will be sure to update you once the release is finished!


It’s working for me since yesterday evening thanks a lot !

1 Like

I have the same problem since yesterday, 24 hours ago. Before that my system is working fine.

I use Raspberry pi 2 + 16 port relay

Since 24 hours ago, the scheduling stop working, before yesterday it was very good, never miss a single schedule.

Forget what i said it’s stop working again…

okay since few day it’s working .

My scheduling (only have 1)and text notifications have not worked for a couple of days now also.

My events started working again since yesterday (arduino events using usb connection with raspberry pi) :slight_smile:

@flammeur @wmontg5988 @costas.petridis @ismail.hirawan Hey guys,

First of all, I apologize for the scheduling bugs that you were experiencing. We’ve recently released some fixes for them (you don’t need to do anything to get these fixes), can you let me know if you still experience scheduling issue?



Argh. I was goin’ nuckin’ futz with this “trigger” issue. (I was…um…“prevented” from posting on this issue)

It’s been freaking me out since mid-December. My “triggers” weren’t reliably triggering events…sometimes it worked, sometimes it didn’t work.

I figured it was on the server side, -since I can “see” when the switch inputs go high or low, and the relays weren’t triggering. However, the “app” buttons always worked…just not the trigger events.

Now I’m trying to deal with the response delays (since I’m using switch inputs as limit switches for garage door controllers, remote gate controllers and curtain controllers). I’m wondering if it wouldn’t be better to “firmware” program the limit switches directly in the ESP8266 device, -bypassing the Cayenne server. Currently, the delayed response is >1.2 seconds when using the ESP12-e. It’s causing my motors to over-current when they hit their physical limits.

I’ve found out that I MUST use re-trigger able 1-shots (pulse stretchers) on my security motion detectors.
A momentary closure can’t be seen by Cayenne unless the closure lasts longer than 1.5 seconds. NOT good! So…that seems to be a solution for Cayenne.

My triggers work as expected since last week, with no problems.
Sorry for the late reply (Christmas time :))

Merry Christmas to all of you

Merry Christmas :slight_smile: And soon happy New Year!