[solved] Not getting a Client ID for MQTT nor a token


Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • NodeMCU ESP-12E

  • Android

Hey everyone, I’ve got a problem with the Dashboard at the moment. I’m having trouble connecting my device because I’m neither getting a token nor a Client ID for my app. I’ve tried to connect through both MQTT and the Cayenne own protocol (not sure what that’s is called).

Is there a problem with issuing connection data like the Client ID or the token at the moment?




#define CAYENNE_PRINT Serial
#include <CayenneMQTTESP8266.h>

// WiFi network info.
char ssid[] = “ssid”;
char wifiPassword[] = “wifiPassword”;

// Cayenne authentication info. This should be obtained from the Cayenne Dashboard.
char username[] = “MQTT_USERNAME”;
char password[] = “MQTT_PASSWORD”;
char clientID[] = “CLIENT_ID”;

unsigned long lastMillis = 0;

void setup() {
Cayenne.begin(username, password, clientID, ssid, wifiPassword);

void loop() {

//Publish data every 10 seconds (10000 milliseconds). Change this value to publish at a different interval.
if (millis() - lastMillis > 10000) {
	lastMillis = millis();
	//Write data to Cayenne here. This example just sends the current uptime in milliseconds.
	Cayenne.virtualWrite(0, lastMillis);
	//Some examples of other functions you can use to send data.
	//Cayenne.celsiusWrite(1, 22.0);
	//Cayenne.luxWrite(2, 700);
	//Cayenne.virtualWrite(3, 50, TYPE_PROXIMITY, UNIT_CENTIMETER);


//Default function for processing actuator commands from the Cayenne Dashboard.
//You can also use functions for specific channels, e.g CAYENNE_IN(1) for channel 1 commands.
CAYENNE_LOG(“CAYENNE_IN_DEFAULT(%u) - %s, %s”, request.channel, getValue.getId(), getValue.asString());
//Process message here. If there is an error set an error message using getValue.setError(), e.g getValue.setError(“Error message”);


Solved: had to delete all data of the app and re-login. Now it’s working.

@amruthrajsagar, not sure how that’s supposed to help me. But never mind, it’s solved. Thanks anyway.