"Upgrade to Arduino Legacy agent 2.0 required"


Hi, I just found out about the update.

can you help me please?

What should I change if I used to have an ESP8266 device with an arduino one through the “classic” connection?

attach the code, greetings!
code ESP8266_ARDUINO.txt (1.7 KB)



I hope it hasnt been a hard cutoff as I have a heap of leonardo based devices that I simply cant make the new MQTT library fit AND do what they did on the Arduino Cayenne library!!!


Hello. with this update I can no longer use the ports as before?
all the doors will have to be virtual
I really did not understand the new functions.
I also have some arduinos connected to a network shield.


Good morning, I have a project at 375 miles, there’s no way I can upgrade to the MQTT project via the internet through the w5100?


Wait, I thought this was done. or not?

“Esp8266 Users: This post applies to you as well if you were connecting your ESP8266 device through our original Arduino option. The only change would be to grab the Cayenne-MQTT-ESP8266 library instead of the Arduino one linked in step #1 below”


Not a hard cut-off :slight_smile:


Hi @aniederauer,

You can still use ports as before and any network shields. Check out this post: Converting Cayenne Arduino LIbrary sketches to Cayenne MQTT Arduino


There is but I think only if you used the Arduino web ide when you uploaded your code. Else, you need to physically upload new code to your Arduino.




Yes, I did send it to the Arduino by the create editor, but it recognizes the COM port and uploads it to the board. My question would be if I can perform an upgrade on the board via ethernet w5100?


Yes you should be able to. When is the next time you can physically go out to your project?



Anything new to report on this? Note all widgets read the same.


have a look at this Converting Cayenne Arduino LIbrary sketches to Cayenne MQTT Arduino


I was under the impression from posts 1-6 and other posts that the unit would be accessible again at some point. Maybe not? There is still no way to reload the page to get valid data but the chart is being updated so that is good. When reloading the page it alternates between the temp and humidity reading populating all the widgets. It was working about an hour ago for a short time. I know there is a lot going on right now so I was just checking in.


Existing remote sites that we CANT get to for some time to upgrade now reporting all sorts of erroneous values etc
Can we have an update on if/when this is going to start working again?
We can’t make the new MQTT library fit into a Leonardo based device and retain the functionality required for the unit to operate as it does (did?) now.


Still have issues with a number of arduino agent sites we cant get to yet to upgrade were all readings are rubbish - any news on a fix? Really cant just drive 2000km to sort this out at the moment!
Every reading same number ie 4 volts, 44%, 4.4mm rain, 4min uptime etc!
We really need this to work or our projects are toast!


So now this has been turned right off? No update to tell us? Multiple clients in field we cant update as the code wont fit in a leonardo - still no answers on heaps of questions regarding that!

Bit annoyed!


hi @tim2 sorry for the inconvenience caused, I will put this to the team and see what we can do. in brief, this are the issues you are facing:

  • MQTT library a bit large for Leonardo.

  • The devices are far away, so you cant update them.

anything else then let me know.


Hi @tim2,

We have done our part to make sure everyone using legacy library have enough time to update their hardware. The legacy library for Arduino is not secured and not scalable, hence, we are deprecating it in favor of a well known standard across the IoT ecosystem, that is MQTT.

Furthermore, we understand that our MQTT library for Arduino is quite big in size, there are couple of reasons for that, primarily easy of use and implementation for new developers/makers. However, we are working on a sample script using a smaller standalone MQTT library for Arduino for this type of use cases.

That’s all we can do at this time, we are sorry for the inconvenience this might have cause, please PM me if you have any other questions or concerns.



PM sent!