Which raspbian release today?

Hi to all,
due the knows problem whith fw 4.9, which raspbian version is right to use today whith cayenne?

fw 4.9 + http://updates.mydevices.com/raspberry/rpi_testing.sh = dashboard shows gpio but can’t control it
fw 4.4 + https://cayenne.mydevices.com/dl/rpi_smu0crfnly.sh = dashboard shows no gpio

  • Raspberry Pi 1 Model B+
  • i use,Web, iOS, Android

Hi @azza976,

That ‘testing’ agent is likely an older version of what we’re eventually going to release to fix 4.9 compatibility, I wouldn’t bother with it at the moment.

Until we make that release (likely in the next week or two) – I would stick to the 4.4 Linux kernel and the agent downloaded by going to Add New > Device/Widget > Single Board Computers > Raspberry Pi in Cayenne. You can update to the 4.4. kernel with the following command:

sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

I know you said you’re having some issue with the GPIO not displaying on 4.4 - if you ran the above command to downgrade, have you also rebooted your Pi afterward? The kernel will not change over until the next boot. I’d say reboot, check uname -a to verify your kernel version, and if it still doesn’t work, let me know the output of service webiopi status

Thanks rsiegel,
here the outpu of “service webiopi status”

Thanks, looks like everything is OK there. Does this reproduce in multiple browsers? It doesn’t seem like there should be any reason for this GPIO page not to be displaying.

yes, multiple browsers and iOS app
if you want I can send to you my password

Yeah if you don’t mind sending that via Private Message, I’ll take a look.

Perhaps it is something specific to the Model B+, I don’t have that one on hand to test, I can see if our QA team does. Has this ever worked on this specific Pi, or is this your first time attempting to connect it to Cayenne?

it was working perfectly until 4.9 firmware upgrade

Thanks for the credentials. After logging into your machine, it looked like while that webiopi service was running, a whole folder of files it was expecting was missing. I’m not quite sure how it got into that state, but I re-installed just the webiopi component and rebooted your Pi, and now it looks like the GPIO page is displaying OK again. Have a look when you have a moment and let me know if it looks OK to you.

I’m done with the account if you want to change any passwords as well :slight_smile:

thank you very much, now it work.

1 Like


I just wanted to bump this thread to note that we’ve now updated our Pi agent to support the 4.9 kernel (it still supports 4.4 as well). The update was automatic in the background so there is nothing you need to do on your end. Feel free to use rpi-update to move forward to the 4.9 kernel at this point if you’d like!

how are you?

I have a problem with triggers.

i have a raspberry (pi2 and pi3 the problem is the same) and need to control 3 relays to pulse one time when request, to do this i always used a trigger but from about 10/15 days triggers not work.

if you want , you can login by ssh port 22 on IP username: pi password:

i also have problem to login ;

thanks in advance for your help


@azza976 I deleted your IP and password, but you might want to check your Pi since that info was public for some time.

1 Like