Bug Filed on 02-25-2016: Triggers not working


#1

1. What OS? (Wheezy or Jessie)


Jessie

2. What class/size SD card? (ex. class 10 16gb)


10GB

3. What Model Pi? (A+, A, B+, B, Pi2)


Pi2

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

I have 2 triggers set up. The first seems to work, the second does not.

1: if temp is below 76f set pwm to .2
2: if temp is above 78f set pwm to .74

The first trigger works, it says ran 1 times. The second trigger never triggers when the temp goes above 78.


#2

Deg C would be nice (hint hint…)
~ Andrew


#3

It’s coming!


#4

bump.


#5

I need to replicate this scenario over here, will update you when I do!


#6

I just realized this as I was trying to replicate on my end and cross referencing your picture… Did you use a PWM output widget for your servo? I think that’s why it’s not working. There is a specific servo widget that needs to be used to control the servo. The pwm output widget goes from .00 to .10, while the servo widget goes from -.45 to +.45

Let me know if this is the case!


#7

I do have PWM widget selected but it is for controlling fan speed not a servo. On the actual trigger it says it has never been run though, so it’s not even getting to the point of doing anything regardless.


#8

Ah I see. Sorry about that, I’ve reproduced and can see that something is off. We’ll work on this. Thanks for reporting!

-B


#9

No worries, I’m glad it wasn’t me doing something dumb haha.


#10

Just noticed there seems to be an error that occurs when my trigger runs, not sure if this is helpful?


#11

Just to add to the ideas an issues…

1/. The time locale setting is good. I am just not sure what is the ‘Default’ time zone if no time zone is chosen could be

  • The Pi time zone setting (raspi-config ?)
  • Cayeene server (PST)
  • Locale time NZ (welly / Akl ) +12 +/- Daylight saving / summer time ?
    The time that comes up seems to be ‘Locale’ set for the Pi but I set this up in raspi-config. Perhaps just needs clarification in the set up screen tool. Could the tool drop or detect the Locale time into the option window ‘by default’ ?

2/. The SMS txt seems too be cleared or hidden after going back and checking it or editing setting. Is this for security or is it set up to send only ONE SMS txt to prevent accidentally generating gazillions of SMS txt/spam/clutter ?

~ Andrew
Setting…


Checking and Editing…


#12

Hey @ats1080s,

We’ve done many incremental improvements to triggers engine. I’m going to move this to Resolved, hope that’s okay with you. If it comes up again, just make another bug post or revive this ones :slight_smile:

-B