CPU Temp not shown in the browser


#1

Hello Everyone,

I am really happy to be a member of this community, also very happy that i found mydevices website it’s very cool!, I have raspberry pi 3 model B with latest Raspbian os and i have an ipad from where i had installed cayenne app and then i added my pi. Everything went without any issues and i can see the following in the IOS Cayenne App on my ipad:

  1. Processor
  2. Memmory
  3. Storage
  4. CPU Temp
  5. DS18B20 Temperature sensor (it has been detected automaticaly)

However i am experiencing an issue when checking the data in the browser from https://cayenne.mydevices.com/ - i am not able to see the CPU Temp - the widget is there but no values inside!? Is it a bug or it’s from my browser? I am using Firefox ESR 52.2.0 (64Bit) under Linux Debian Stretch.
I will try from another browser as well, hope it will be fixed soon.

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)

  • What dashboard are you using? (Web, iOS, Android)

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!


#2

I have also tested it from windows with Chrome browser, and from Linux with Chromium browser and the issue still persist. Please someone to tell me some workaround how to fix this issue since CPU Temp is important for me.

Many thanks in advance and looking forward for some reply.


#3

Hi @emil.tsvetanov, and welcome to the Cayenne community.

That’s one I haven’t seen before – do you mind sharing your account login/password via private message so I can reproduce/investigate on our end? You can PM me by clicking my name, then the blue ‘Message’ button’. You can also use this form to reset your password before/after sharing if you’d like.


#4

Hello rsiegel,

Thank you for your reply.
Sure i will PM you.

Regards,
Emil


#5

Thanks for sharing. I can see the same behavior in my side. I’m not entirely sure how the widget got in this state, but I did find some other ways to break these default Pi widgets by first editing them on iOS which then changes them into an unexpected state on the web. I think if we squash these, we’ll squash your bug too.

For your immediate case, try going to the Settings gear > Reset Dashboard. This should return your default PI widgets to their default state, which should cause the temperature to display again. You may need to reconfigure things like widget icons after the reset. I’d suggest to do that from the web rather than from iOS right now to avoid the issues I ran into.


#6

Hello,

After reseting the Dashboard from the Browser now it’s displayed! Also the network usage it’s displayed. Thank you very much!!!

Regards,
Emil Tsvetanov


#7

Hello @emil.tsvetanov

Don’t forget that you can make a new project and add/remove different widgets that cannot be removed in the default dashboard of a specific device. This function is very cool for making a project that combines different devices and communication methods.

Best Wishes,
Ognyan Chikov


#8

Yeah, the crux of the issue here is that Pi default widgets (CPU/RAM/Storage/CPU Temp/Processes/Network Speed) should not have ‘Remove’ buttons at all (by design, since there is no way to re-create them and you can always just leave them out of a Project view). For some reason adding icons to them in iOS causes this Remove button to appear on web and they get in a bad state. We’ll squash it! :ant: