Agent 2.0 upgrade


Hello, sorry ahead of time for the dumb question. How do I upgrade my RaspberryPis to the Pi agent 2.0?


on the dashboard go to : add new > device/widget > raspberry pi > and type the command in the ssh terminal.


Ok, is it best to start over with a new SD card image or can you use one that’s already connected to Cayenne?


it is recommended to start on new sd-card.


After doing this i still get the old agent.

Made a fresh stretch light sdcard and added it as a new device and it still ends up with the old agent any ideas?


what do you mean with old agent?


When i log on to the cayenne website after newly adding my pi, i still get the popup that its using the legacy version and when i check it on the webpage it still sais its using Agent Version


And not even run apt-get update/upgrade before Cayenne install, because then it will crash with the newer Python version.


Hello, is the DS18B20 still supported automatically with the 2.0 agent?


yes it should be. have a look at this


Ok, haven’t been able to get it to work. Is the new RaspberryPi 3 B+ supported?


yes. what is problem you are facing.


Just trying to add the ds18b20 but it doesn’t come up after connecting to the GPIO and booting.


hold on, there seems to be some bug with agent 2.0. will notify once it is solved.


Need help, no success on agent 2.0 install. Tried run Terminal/ssh commands but after more than 20 hours the process is stuck yet. It’s not my first try, but this time I’ve waited more. Android app says only “waiting for board to connect”.

Fresh SD card is out of question.

Below are screens of webiopi and myDevices services.

● myDevices.service - myDevices service
Loaded: loaded (/etc/systemd/system/myDevices.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Mon 2018-06-04 18:52:18 -03; 8s ago
Process: 6832 ExecStart=/usr/bin/python3 -m myDevices -P /var/run/myDevices/ (code=exited, status=0/SUCCESS)
Process: 6829 ExecStartPre=/bin/chown cayenne:cayenne /etc/myDevices/devices.json (code=exited, status=1/FAILURE)
Process: 6826 ExecStartPre=/bin/chown cayenne:cayenne /etc/myDevices/agent.db* (code=exited, status=1/FAILURE)
Process: 6823 ExecStartPre=/bin/chown cayenne:cayenne /etc/myDevices/AppSettings.ini (code=exited, status=0/SUCCESS)
Process: 6820 ExecStartPre=/bin/chown cayenne:cayenne /etc/myDevices (code=exited, status=0/SUCCESS)
Process: 6817 ExecStartPre=/bin/chown -R cayenne:cayenne /var/log/myDevices/ (code=exited, status=0/SUCCESS)
Process: 6814 ExecStartPre=/bin/mkdir -p /var/log/myDevices (code=exited, status=0/SUCCESS)
Process: 6811 ExecStartPre=/bin/chown cayenne:cayenne /var/run/myDevices/ (code=exited, status=0/SUCCESS)
Process: 6808 ExecStartPre=/bin/mkdir -p /var/run/myDevices (code=exited, status=0/SUCCESS)
Main PID: 6832 (code=exited, status=0/SUCCESS)

jun 04 18:52:02 raspberrypi systemd[1]: Starting myDevices service…
jun 04 18:52:02 raspberrypi systemd[1]: Started myDevices service.
jun 04 18:52:02 raspberrypi systemd[6832]: pam_unix(login:session): session opened for user cayenne by (uid=0)

● webiopi.service - LSB: WebIOPi initscript
Loaded: loaded (/etc/init.d/webiopi; generated; vendor preset: enabled)
Active: active (running) since Sun 2018-06-03 23:41:23 -03; 19h ago
Docs: man:systemd-sysv-generator(8)
Process: 593 ExecStart=/etc/init.d/webiopi start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/webiopi.service
└─660 /usr/bin/python3 -m webiopi -l /var/log/webiopi -c /etc/webiopi/config

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.


Hi @aicraga, I’m sorry you are having problems upgrading the Pi with a new agent.

10 minutes should be more than enough to install/add a new pi. Did you try adding upgrading from the web dashboard as well, or only through android? If not, I would strongly suggest adding the pi through the web dashboard.


Tried only from web dashboard, just saw that status on Android as another support information.


What version of raspbian do you have installed in that device?


It is a Pi3 with “Raspbian GNU/Linux 9 (stretch)” 4.14.34-v7+ #1110 SMP


Ok, I’ll refer this to one of our engineers and see if he can help you troubleshoot.

I assume you don’t want to use a fresh card because you have other stuff running on that pi, correct? Can you still, for test only, use a new formatted SD card, fresh install raspbian and add it to Cayenne and see if it connects correctly?