Unable to add raspberry


Hello I am using raspberry pi2 B

I am using web and android dashboard.

My device went offline and cannot connect to cayenne anymore.

I tried to remove old device and install a new one without success. Cayenne is able to find my raspberry but the installation gets stuck. I tried installing from web, androind and fromn ssh.

I have tried to fix it for two days now but installation of new one fails.

i am trying to control a greenhouse. this kind of fails are unacceptable


Can you go the web dashboard and click on the pi, go to the settings and see what the version of the agent? It could be that you need to update to our new agent.


web dashboard is empty

I tried once again with android --> nothing looking for a device…

Still ssh connects succesfully


How do I find the settings which contains the version information?


I found it. There is no information… the field is blank and raspberry says it is offline


Is that the only field that shows blank?


everything is blank


Now I was able to get the raspberry back online. Now scheduling does not work I cannot add widgets to projects… Lots of features missing. Now the agent is 2.0 something.

Is this going to be fixed soon?


I’m glad you were able to connect. I was actually trying to replicate the behavior and was working well on my end. I think what happened to you is you were using the old agent, and that has been having problems and we are actually ending support for old agent July 1st. We sent an email back a few weeks ago reminding of this change.

You should be able to add widgets to projects. Just drag the device to the project dashboard and select the sensors you need.

Yes, scheduling is not working yet with our new agent and we will add support, but we don’t have an ETA yet. Please see Raspberry Pi Agent 2.0 for current limitations.