Arduino shield help

i have a “Raspberry Pi Meet Arduino Shield” from dfrobot

they demo an LED project with this thing just snapped onto a pi 3 in python. i am trying the same setup for my project, but it will not install the cayenne library

any help would be greatly appreciated

What’s the error you are getting?

i am trying to adopt it and it shows the arduino shield, but it doesn’t show it connecting, and i get arduino ide errors. i have even tried commenting out #include <ESP8266_SoftSer.h> but it shows a different wifi error after i do

here’s my steps:

serial connection

Arduino ide:
board: “Arduino Leonardo”
port: "dev/tty/ACM0

Arduino: 1.8.5 (Linux), Board: “Arduino Leonardo”

/home/pi/Downloads/arduino-1.8.5/arduino-builder -dump-prefs -logger=machine -hardware /home/pi/Downloads/arduino-1.8.5/hardware -tools /home/pi/Downloads/arduino-1.8.5/tools-builder -tools /home/pi/Downloads/arduino-1.8.5/hardware/tools/avr -built-in-libraries /home/pi/Downloads/arduino-1.8.5/libraries -libraries /home/pi/Arduino/libraries -fqbn=arduino:avr:leonardo -vid-pid=0X2341_0X8036 -ide-version=10805 -build-path /tmp/arduino_build_919951 -warnings=none -build-cache /tmp/arduino_cache_403665 -prefs=build.warn_data_percentage=75 -verbose /home/pi/Arduino/sketch_dec07a/sketch_dec07a.ino
/home/pi/Downloads/arduino-1.8.5/arduino-builder -compile -logger=machine -hardware /home/pi/Downloads/arduino-1.8.5/hardware -tools /home/pi/Downloads/arduino-1.8.5/tools-builder -tools /home/pi/Downloads/arduino-1.8.5/hardware/tools/avr -built-in-libraries /home/pi/Downloads/arduino-1.8.5/libraries -libraries /home/pi/Arduino/libraries -fqbn=arduino:avr:leonardo -vid-pid=0X2341_0X8036 -ide-version=10805 -build-path /tmp/arduino_build_919951 -warnings=none -build-cache /tmp/arduino_cache_403665 -prefs=build.warn_data_percentage=75 -verbose /home/pi/Arduino/sketch_dec07a/sketch_dec07a.ino
Using board ‘leonardo’ from platform in folder: /home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr
Using core ‘arduino’ from platform in folder: /home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr
Detecting libraries used…
“/home/pi/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_LEONARDO -DARDUINO_ARCH_AVR -DUSB_VID=0x2341 -DUSB_PID=0x8036 ‘-DUSB_MANUFACTURER=“Unknown”’ ‘-DUSB_PRODUCT=“Arduino Leonardo”’ “-I/home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr/cores/arduino” “-I/home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr/variants/leonardo” “/tmp/arduino_build_919951/sketch/sketch_dec07a.ino.cpp” -o “/dev/null”
“/home/pi/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_LEONARDO -DARDUINO_ARCH_AVR -DUSB_VID=0x2341 -DUSB_PID=0x8036 ‘-DUSB_MANUFACTURER=“Unknown”’ ‘-DUSB_PRODUCT=“Arduino Leonardo”’ “-I/home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr/cores/arduino” “-I/home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr/variants/leonardo” “-I/home/pi/Arduino/libraries/Cayenne” “/tmp/arduino_build_919951/sketch/sketch_dec07a.ino.cpp” -o “/dev/null”
“/home/pi/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_LEONARDO -DARDUINO_ARCH_AVR -DUSB_VID=0x2341 -DUSB_PID=0x8036 ‘-DUSB_MANUFACTURER=“Unknown”’ ‘-DUSB_PRODUCT=“Arduino Leonardo”’ “-I/home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr/cores/arduino” “-I/home/pi/Downloads/arduino-1.8.5/hardware/arduino/avr/variants/leonardo” “-I/home/pi/Arduino/libraries/Cayenne” “/tmp/arduino_build_919951/sketch/sketch_dec07a.ino.cpp” -o “/tmp/arduino_build_919951/preproc/ctags_target_for_gcc_minus_e.cpp”
In file included from /home/pi/Arduino/sketch_dec07a/sketch_dec07a.ino:1:0:
/home/pi/Arduino/libraries/Cayenne/BlynkSimpleShieldEsp8266_SoftSer.h:27:29: fatal error: ESP8266_SoftSer.h: No such file or directory
#include <ESP8266_SoftSer.h>
compilation terminated.
Using library Cayenne at version 1.0.2 in folder: /home/pi/Arduino/libraries/Cayenne
exit status 1
Error compiling for board Arduino Leonardo.

Can you post the code you are using when you get this error?

I am copying the sketch from the cayenne site

There’s a lot of example code out there, can you post the specif one you are using?

this is what i get after trying to upload the cayenne library with the
leonardo, serial port, and ACM0. the board is directly plugged into the
gpio on the pi 3, so i was assuming it would use the pi’s internet
connection because it does on the dfrobot page. there is even an LED demo
for this arduino board on a few sites. here is the board itself:

when i try to upload the library, i get this (attachment 1)

to see if i could make any progress, i run this in the arduino IDE. i don’t
get an error here, it just never connects to cayenne.

should this board possibly have it’s own wifi? or the RTC built in be

#include <CayenneSerial.h>
// Cayenne authentication token. This should be obtained from the
Cayenne Dashboard.char token = “xxxxxxxxxxx”;
void setup(){
//Baud rate can be specified by calling Cayenne.begin(token, 9600);
void loop(){;}

1.txt (4.45 KB)