Arduino uno and Shield W5100 events not working


#1

I just did my project all the actuators and sensors and triggers work perfectly, but the events scheduled for the actuators do not work, I’ve done everything but nothing anyone please help me


#2

Welcome to the cayenne community @jlcamilo77.
currently scheduling is not supported. we are working on it and will have an release in upcoming week.


#3

Thank you very much for replying, I’ll be waiting.


#4

Events are not working yet
some prediction for when problem will be solved
Thank you so far


#5

Add a new device using Bring your own thing and give scheduler a try.


#6

Wonder is working now.
Thank you very much


#7

Events work for my device
but for others I add do not work
I’ve seen some information that can help solve the problem.
But I do not know how to solve it.
this works perfectly

But this does not
because this information appears in white and the previous one does not

The two devices are arduino one and ethernet shield


#8

the device in first picture is of Bring Your Own Thing while second one is using an Arduino device.


#9

The 2 devices are
adder one + ethernet shield
I noticed that the first one that does not contain hardware information and version events, triggers, email notification and all trigger buttons work perfectly
But the second that is identical to the first even the code that appears the white information of hardware and version the events per hour do not work, trigger, email and trigger buttons work perfectly
I tested with another account and the problem persists, there is a solution
Remembering that I’m using the same arduino and ethernet shield for different accounts, the cayenne server does some association with account and sn / device


#10

that what i am trying to tell you. the first device is added using Bring Your Own Thing while the second one is using an Arduino option.


#11

Thank you very much very much I did not understand now, it works perfectly I’m sorry I did not understand the difference between adding a device andBring Your Own Thing


#12

I have another problem
the app for adroid version 1.52 is not working, I am using version 1.51
android version 6.01
follow photo


#13

when does the app stops? while you open the app or while using button on device or trigger or something else? Also which company mobile are you using?


#14

When I open the application in version 1.52 it already informs the problem
I tested it with other phones with android version 6.01 and the problem persists for ios works perfectly I will check in higher versions and then I am currently reporting using version 1.51 that is working


#15

I tested on an android version 8.0
and the problem persists
I’ll see if I can test with another arduino


#16

The 2 phones I tested are Sansung Galaxy with Android 6.01 and 8.0
TIM and Claro operator


#17

thanks for the details. team will look into this.


#18

Today I tested it and another cell phone and it worked.
I tested it on my phone and now version 1.52 is ok


#19

Glad to hear that it is working now?


#20

Shramiksalgaonkar
Firstly Cayenne is the best internet application of the things I’ve known
So far without much knowledge I managed to automate everything in my house
lights
Gas, co2, temperature, lux and humidity sensors
Audio, video and tv control with ircode
But I have a problem.
I added physical pushbuttons to trigger lights, attached pins in arduino, while internet connected
everything works 100% by triggering by the cayenne app, browser and button, the lights turn on and off, and update status
But when no internet connection physical button does not work, after reconnect back to work
I tried doing a WHILE with CAYENNE_CONNECTED () and CAYENNE_DISCONNECTED () but it did not work
I realized that after Cayenne.loop () starts no longer
Is there any way to stop Cayenne.loop () when the internet is off
Here’s how I tried to do it.
I will shorten to get better

#define VIRTUAL_CHANNEL 1
#define RELE7_PIN 7
#define BUTTON1_PIN 8
boolean onlineStatus = false;
int state = 0;

void setup () {
Serial.begin (9600);

Cayenne.begin (username, password, clientID);

pinMode (BUTTON1_PIN, INPUT_PULLUP);

pinMode (RELE7_PIN, OUTPUT);

    digitalWrite (RELE7_PIN, EEPROM.read (1));

}
CAYENNE_CONNECTED () {onlineStatus = true;}
CAYENNE_DISCONNECTED () {onlineStatus = false;}
void loop () {

while (onlineStatus = false) {
if (digitalRead (BUTTON1_PIN) == LOW) {
int state = digitalRead (RELE7_PIN);
digitalWrite (RELE7_PIN,! state);
}
}
while (onlineStatus = true) {
Cayenne.loop ();

Cayenne.virtualWrite (1, digitalRead (7));
delay (100);
}
}
CAYENNE_IN (1)
{
int value = getValue.asInt ();
digitalWrite (RELE7_PIN, value);
delay (100);
EEPROM.update (6, digitalRead (7));

}
If you can help me, thank you.