Bug Filed on 02-05-2016: iOS App could not find pi because it was not on wifi



1. What OS? (Wheezy or Jessie)


2. What class/size SD card? (ex. class 10 16gb)

class 10 32 gb

3. What Model Pi? (A+, A, B+, B, Pi2)


4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

pi connected to network via ethernet.
iPad wireless
iOS App never found pi.
It was super easy to install the software once I found the two lines on your website.
Now both my Mac and iPad communicate with my pi just fine.

I think it would be a swell idea to include feedback within the iOS App which includes all the pertinent details so it would be easier for beta testers to provide accurate information.

Thanks for a very interesting product!


Hi Jeff,

Hmmm. Was your phone connected to the same network as your Pi? For example, if the Pi was connected to ethernet on ‘homenetwork’, and phone was connected to WiFi on ‘homenetwork’, then the iOS app should have found the Pi.

Perhaps your phone was connected to normal mobile data, and not the same network as you Pi? Once we figure out if our Pi discovery feature is not working in certain cases we can make a change.

Also, what pertinent details were you thinking? Details that there is also a web dashboard to use?



Hi Benny.
Both my iPad and my pi are connected to the internet by the same router. The iPad is of course wifi (5 gHz), the pi hardwired via ethernet. I am able to SSH into the pi from other iOS Apps. Once the agent was installed on the pi the iOS App worked! Only the discovery process failed. I was trying to use the iOS App to to install the agent as shown on your web site.

This should be easy to reproduce.
It is very easy to install the agent from the terminal on the pi.
It would be really easy if you included the agent with the add/remove software in the latest Jessie release!

What I meant by pertinent details are all information about version numbers, which Linux distribution, which might help a developer reproduce the bug.

Let me know if I can be of assistance.
I have a Mac with iOS development environment installed and have used TestFlight.


I will definitely let you know of assistance, thanks!

Did you set your Pi up with a different login / password than the default pi / raspberry?


Changed password back to default.
No change on iOS App.
Web based client can access and control pi.
BTW - there are several versions of the manual agent install on the website.
It would be a good idea to post the most current version in just one place and refer to it so as to avoid confusion.


Hey Jeff,

So to confirm, the iOS app wasn’t able to find the raspberry pi on your network? But after you installed the agent manually, it showed up on the iOS app, right?
If so, could you try doing this:

  1. Logging out (Settings->Log Out)
  2. Create a new account
  3. Search again
  4. If it doesn’t come up could you try pinging the Raspberry Pi on your network and see if it responds?

Thanks for the feedback!



Hi Tim.
Your assumptions are correct.
I can ping the pi just fine.
I made a new web account.
Deleted and re-installed the iOS App.
iOS app never finds the pi.
I tried this on latest pi 2 and older pi model B.
Only after starting the web dashboard can the iOS device find the pi 2.
Never got the pi model B to work.
BTW dashboard on iOS app and web are using different calculations.
For example, on the iOS app, the storage used is rounded up and the entire size of the card is used where on the web dashboard, the storage used is calculated to one decimal place and the formatted size of the card is being used.
I also noticed on the web dashboard when it is offline, the values persist in the display when they really should be cleared.


We haven’t encountered this before. We’ve always been able to detect the Pi on the network. I’m assuming you have no abnormal network configurations.

This is totally optional for you, but do you have any time to jump on a skype call and debug with Tim and I? Or perhaps you can send a video of going through the steps… This would help us out a lot so we can hopefully prevent this from happening in future. Again, absolutely fine if you don’t have the time.

Maybe PM me or email me so we can take this off the thread? bestes@mydevices.com



Some Comcast modem/router/access points separate the wifi and lan on different VLAN’s for some reason, what model access point are you using? Also check your IP address info (IP, subnet, and default gateway) on both devices to make sure that they are on the same network.


Thanks @ats1080s. @w8fun think you could look into that?


Not a problem like that as I own my own MODEM and router.
I think I will wait until this product is more mature before I try it again.
Thanks. You can close this one.


Sounds good, appreciate your time!




I’d just like to mention that I had this same issue. The iOS app would not detect my pi B+ despite it being on the same subnet and pingable. My phone was connected to the same WiFi network as my pi. I had also changed the default password on my pi so maybe that’s the cause?

Regardless, I was able to install via SSH and now it appears to be working.

Maybe it would be helpful to have the iOS app recommend the SSH installation method if it’s not able to detect the device after a certain period of time.


Bug Filed on 03-28-2016: iOS App Not Detecting Raspberry Pi

Hi Ian,

Darn, we’ve been trying to pinpoint a reason why the Pi could not get discovered, unable to reproduce thus far on our end…We’ll be going through some deeper testing of each Pi version and OS and iPhone etc. Hoping this will produce some results for us.

Anyway, thanks for reporting to us. If no one reports then we don’t know about these issues! That’s a great recommendation that makes a lot of sense. I can imagine if your Pi doesn’t get found it would be frustrating to just sit on the screen with no direction of where to go next. We’ll get some UX out to accommodate this.

What iOS version are you using and what iPhone model? (6, 6s, etc)



Thanks for your prompt response! My iOS version is 9.2.1 and my phone is an iPhone 6s.


@ianwladd @w8fun @ats1080s Wanted to update you guys. We have a fix in place that improves the discovery feature on the iOS app. We were finally able to reproduce the iOS app not being able to detect the Pi on the network, and with the fix, the iOS app was able to detect that same Pi on the network.

We’ll push this fix with the next update to the iOS app. Hoping you’ll be able to verify that the fix indeed works! Anyway, it’s coming!



@ianwladd @w8fun @ats1080s Hey guys! An updated Cayenne iOS app has been approved by Apple and updated on the Apple Store. If you could please update the new version and let me know if your Pi can now be discovered. Thanks!

I will resolve this topic, let’s open another one if there are discovery issues.