Bug Filed on 02-25-2016: Install fails in Installing myDevices agent


#1

1. What OS? (Wheezy or Jessie) Jessie


2. What class/size SD card? (ex. class 10 16gb) 16gb


3. What Model Pi? (A+, A, B+, B, Pi2) B


4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

I could not install from the IOS app. It just hung.

I did expand the SD card and have a successful Jessie install.

wget --content-disposition https://cayenne.mydevices.com/dl/zwjw68a9d0 runs successfully.

sudo sh rpi_zwjw68a9d0.sh -v gets very far but fails when it gets to the agent install.

Setup requires at least 200Mb for install.

Any ideas?


#2

What is the output of df -h?


#3


#4

That doesn’t look like the default paritioning, did you change it? It should look similar to this:

`pi@raspberrypi:~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       7.2G  3.4G  3.5G  49% /
devtmpfs        459M     0  459M   0% /dev
tmpfs           463M     0  463M   0% /dev/shm
tmpfs           463M  6.3M  457M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           463M     0  463M   0% /sys/fs/cgroup
/dev/mmcblk0p1   60M   20M   41M  34% /boot
tmpfs            93M     0   93M   0% /run/user/1000`

Regardless, /dev, /net, /home, and /Volumes/boot are 100% full and that’s more than likely what is causing your problem.


Bug Filed on 03-01-2016: Install Fails (Fix Edit: need to expand file system)
#5

@ats1080s
Thanks Adam! I just lernt sumthin!
I was looking at Paul’s output and was wondering why the difference compaired to what I got on one of my RPi’s.

Filesystem      Size  Used Avail Use% Mounted on
/dev/root        15G  6.2G  7.4G  46% /
devtmpfs        459M     0  459M   0% /dev
tmpfs           463M     0  463M   0% /dev/shm
tmpfs           463M   47M  417M  11% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           463M     0  463M   0% /sys/fs/cgroup
/dev/mmcblk0p1   56M   20M   37M  36% /boot
tmpfs            93M  4.0K   93M   1% /run/user/1000
tmpfs            93M     0   93M   0% /run/user/0

-Ian


#6

Hmmm… I may not have expanded the filesystem with raspi-config. I am going to start from scratch on this SD card and see if that does the trick.


#7

@paulcbrewer
Good luck Paul!

-Ian


#8

Thanks for the suggestions/tips.

Same result.

Here is my procedure:

  • This time I used a utility to reformat the SD card as FAT32 just to get a clean starting point
  • I’m on MacOS so I followed the steps here: https://www.raspberrypi.org/documentation/installation/installing-images/mac.md
  • Erase the SD cards partition with sudo diskutil partitionDisk /dev/disk2 1 MBR “Free Space” “%noformat%” 100% I have tried this install with and without that step and gotten the same result.

After that step I have this:

Which does not look promising.

Pushing ahead, I unmount the disk: diskutil unmountDisk /dev/disk2

And do the copy: sudo dd bs=1m if=2016-02-09-raspbian-jessie.img of=/dev/rdisk2

Then expand the filesystem using raspi-config and end up with:

This should not be that hard. What it the world am I doing wrong???


#9

Ok, so you were using df -h on your mac, that makes a lot more sense. You want to open an SSH session to your pi (I don’t have a mac but I’m pretty sure you can just type in the terminal “ssh ip.addr.of.pi” - obviously using your pi’s ip address) and use df -h there. I was wondering why you had 260GB of storage on your pi lol. To expand the file system on the pi you want SSH to the pi and use the raspi-config utility and it will automatically do it for you.

Maybe it would be a good idea to check for free space before the installer starts and either recommend running raspi-config on fail or add an option to expand the file system through the installer? This seems to be a pretty common problem.


#10

As ats1080s suggested previously, it sounds as though the SD card hasn’t been expanded yet.
Type in sudo raspi-config
Select option 1 to Expand Filesystem.
Click OK.
Click Finish.
Once your Pi reboots, you should be able to install either way (Through the iOS app or on the Pi/SSH).


#11

Hey @paulcbrewer the reason why the iOS app hangs on install on Step 1 out of 4 is because the SD card is not properly expanded (like the others were saying). However, right now the iOS app doesn’t return an error when the install fails so that’s why it hangs. In the next update, this will be fixed, so it will tell you if you did not expand the filesystem correctly or if anything else failed.

All the best,
-Tim


#12

Art, Adam, Ian, Tim… Thank you!


#13

Excellent! Great to hear Paul. Hopefully you have all the hard parts behind you. Now the fun begins, get some sensors, set some triggers, make things happen.

Enjoy,
-Ian


#14

Those I do not lack for. I am a long time Arduino tinkerer. I am really looking forward to seeing what I can do with the Cayenne platform.

Thanks again!

Paul


#15

Be sure to submit your project to the ‘Projects made with Cayenne’ category. Can’t wait to see!


#16

@ats1080s @Ian Thanks for jumping in and helping out here guys.


#17

Part of my aquarium project is to combine the already in place Arduino that is controlling the RGB LED lighting with the newly installed TSL2561 that is on my PiZero to have the lights set appropriately for the fish depending on ambient light conditions.

Enjoy,

-Ian


#18

Hi,

I have the same problem the install on the Raspberry goes file.
Partition table is all good (15GB) free

But the install screen hangs on the Agent:

I’m running this version:

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

Please help :wink:


#19

Hi Kay,

Welcome to the Cayenne Community! So, you have expanded your filesystem and you are using Jessie Full? Have you already followed the steps listed in this thread?

-B


#20

How can i see if i have Jessie lite / full?
Install the thing a while back…

Partition Layout:
And i can remember that i expanded it…
I’m now running the Dymo printserver on it… That’s all

pi@raspberrypi:~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 15G 1.3G 13G 9% /
devtmpfs 459M 0 459M 0% /dev
tmpfs 463M 0 463M 0% /dev/shm
tmpfs 463M 6.3M 457M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 463M 0 463M 0% /sys/fs/cgroup
/dev/mmcblk0p1 60M 20M 41M 34% /boot
tmpfs 93M 0 93M 0% /run/user/1000