Bug Filed on 02-19-2016: Pi drop outs

1. What OS? (Wheezy or Jessie)


2. What class/size SD card? (ex. class 10 16gb)

8Gb class 10

3. What Model Pi? (A+, A, B+, B, Pi2)


4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

I have 4 Pi’s connected, and two of them keep dropping out randomly (both on Wheezy, the other two are on Jesse and their drop outs aren’t as often, and they do come back online). One Pi on Wheezy has dropped out for days. Both are on different networks. Just wondering if the “phone-home” port is blocked?


Hello Ben

Thank you for reporting this. Can you tell me do they go offline for long periods of time or is it for an instant and comes back online. How many networks do you have? Are they located in different places, such as one at work, one at home, etc? I am curious whether this would still happen if you added them all on the same network. Also are they connected through Wifi or Hard wired to the network. Are there any differences between the network? Wired, 2.4, 5ghz etc.

Please let us know and we can investigate further.


@svazir, I have seen similar activity in 2 of my 4 Pi’s (3 RPi2b, 1 Zero). All 4 plugged into the same router, all 4 w/ full Jessie. Today is my Friday so I will have some time to assemble some more data for you in the next 4 days.


Hi Sumeet,

Sorry about the late reply, was just waiting for some drop outs to occur.

I have a Pi at work thats behind a harden firewall which ticks along nicely, with not dropouts that I have seen. I have a Pi connected to a remote ADSL service that I installed and it worked for a few hour, I was able to SSH to it, but I just tried and can’t anymore, so its a power issue. The remain 2 Pi’s are on my home network, both wired, and same subnet. Below is a screenshot of SMS alerts from “ControlPi” (one of the Pi’s on my home network) when it dropped out a moment ago.


Here is the list of on/offline triggers on 3 of my RPi’s over approximately a 3 hour period.

Just so you can get the lay of the land -
RPi Zero - is a RPiZero that is WiFi’d into a NETGEAR AC1200 router
RPi DVK512 - is a RPi2b that is plugged (ethernet) into the same router as the Zero
RPi in/out 18B20 - is a RPi2b that is plugged into the same router as the other two

As you can see DVK512 has had many trigger activations, The Zero has been fairly stable, which is a little unusual compared to previous days, and the 18B20 is my super hero, rock steady.

Let me know if you want to poke around the Pi’s. I’ll PM you my login credentials, assuming Benny hasn’t written them on the bathroom wall there at the home office.


Hi My Pi’s are also dropping out randomly. I set up a pi zero 3 days ago with Jessie, 16 Gb class 10 card. Over the last 3 days it will drop out after 20 minutes or several hours. Pi is still connected to the internet and I ssh into it, do a reboot in order to reconnect. The other Pi that is doing the same thing is an A+ with 8Gb card. Right now just running the pi zero.



Instead of a reboot, this usually works for me.
sudo service myDevices restart

Doesn’t solve the underlying problem, but seems to get things ticking again for me.


Thanks for that tip…maybe I will automate this to run this every couple hours.

Also a great tip.

Unfortunate to have to code on the no-code platform though. Of course if things were perfect here it wouldn’t be any fun.


It’s easy enough to do (I haven’t tested this but should work - double check case sensitive service names):

sudo crontab -l | { cat; echo “0 * * * * service myDevices restart && service webiopi restart”; } | crontab -

This will restart both services every hour

1 Like

Would it hurt any thing to put something like this or a watchdog in the distro?


Ideally the root issue should be fixed :slight_smile: Do you see anything relevant in your logs? If not, run mydevices in debug mode:

sudo service myDevices stop
sudo myDevices -d

You can set up putty to log to a file if you are seeing too much activity and it is scrolling off the screen:

1 Like

Thanks Adam!
I’ll give it a look when I get home. Sadly I have to spend the afternoon in Denver, good news is that there is a Microcenter near where I’m going, so maybe I can pick up some more sensors or Pi’s.


Thanks guys for all the good information we will investigate this issue and hopefully will have a fix for this soon.

@tdeleanu can you please look into this issue.



Thanks a lot for the notice guys.
Some logs or access to the specific PI’s will be a major boost to debug.
So please let me know what is available!

Agreed, the root issue should be fixed.

@stevev4772 think you can PM me your login credentials so we can take a look?

I can be of assistance if anyone needs access to a Pi or logs.

Just here to help :grin: :+1:

Do you think you can PM @tdeleanu and I your credentials, and also the logs. Thank you!


Sorry for the late reply Benny. Would you still like access to a Pi?

Yes we would like the credentials please can you PM it to @bestes and @tdeleanu