Bug Filed on 03-28-2016: Unable to remove Widget from Dashboard

1. What OS? (Wheezy or Jessie)


2. What class/size SD card? (ex. class 10 16gb)

class 10 8gb

3. What Model Pi? (A+, A, B+, B, Pi2)


4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

I have added a relay actuator to my dashboard but i choosen wrong the gpio pin, now i’m unable to remove it… It stay saying removing and nothing happens. Have rebooted pi, deleted cache and the same… Some help please :slight_smile:

Hmmm. Refresh the page and try to remove again (even if the ‘Removing…’ text is still there).

You could also press the ‘Reset’ button in blue ribbon bar at top. Though, this will reset all widgets and you’ll have to re-do the settings, so be aware.

I will try to reproduce this by adding a widget to a pin that also has nothing connected to it. Perhaps we never tested removing a widget from a pin where nothing can be removed. You should be able to remove a widget regardless. We’ll investigate this.


have done all the steps you indicate and no luck. Still unable to remove it.


By the way it is associated to gpio 20

Darn, I haven’t been able to reproduce. We’ll investigate into this though. Keep you updated.


1 Like

Have you find out this problem? I have done a clean install and the widget is not there anymore. Have tried to replicate the problem and i there it goes again.

Can you try if you name the widget like mine if you are able to delete it

Name: Resistencia On/Off


I seem to be having the same issue.
Reset is not deleting anything.

Only difference is I’m using Pi3 and 16GB

Press reset.

Hi @scheltovandoorn,

You are trying to remove a default widget that is not able to be removed (memory, processor, storage). The work around is to remove the widget from your project dashboard. …click the settings of the widget and you should see ‘remove from project’.

In future, we will take away the ‘remove’ button from the default widgets so this cannot occur.

Thanks for posting!


unfortunately, I was not able to reproduce. I tried multiple ways too, including naming my widget ‘Resistencia On/Off’.

@eptak do you have any idea why this might happen?


Thanks for the ‘remove from project’ tip. I’m making progress.

I’m having a similar issue. I have one-wire sensors that refuse to remove from dashboards on 2 different Pi’s.
The sensors are not physically connected and I cannot find a combination of reset/reboot that will actually remove them. When attempting to remove the sensor from the widget settings window, there is a red circle w/line cursor when I hover over the remove sensor button, despite the sensor not actually being connected.

I had some success by logging out and then logging back in to refresh some devices in the desktop version.
And I just found out, a page refresh in the browser will also do the trick. (for me using Chrome))

This is a bug that we’ll be releasing a fix for after Arduino integration gets out the door. Once a 1-wire sensor successfully gets added to dashboard w/ slave address, there is not way to delete the widget from dashboard. We will fix this!


1 Like

Wooot! Mark this down as fixed for me!

Just checked back in on a test pi and decided to try dropping the two ghost one wire temp probes that didn’t want to leave…bam! Gone.

Thanks to you and the team for the work you put into this!

March 25 2017, Arduino Uno (Ether Shield), added some luminosity actuators then tried to remove. This done via Chrome (Version 56.0.2924.87 (64-bit)) on Mac (Sierra 10.12.3) and widget remains as ‘Removing’ state.

Clicked ‘Reset’ in blue bar and that solved the issue, but still seems like something that shouldnt be happening in the first place.


I have been having a play and have added and deleted some widgets multiple times. I now have a collection of widgets on the left bar all called tank level 1 that are now not required. I also have 1 “tank Level 1” that is still current. How do I get rid of the reaining widgets (even though they are not on the project)


How do I delete them?

you need to remove the device and add a new device. Those are ghost widget and nothing can be done.

Thanks for your quick reply