Bug Filed on 08-29-2016: Cannot remove widgets


What dashboard are you using? (Web, iOS, Android)

What OS? (Jessie, Wheezy)
Windows 7

What Model Pi?
Arduino Uno + WiFi Shield

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

I’ve create two widgets (one input and one output), then I tried to remove using “settings” - “remove widget”… now the icon on the widget is a spinning circle and the status “removing”; two hour later nothing is changed and the widgets aren’t deleted yet!
Tried with IE and Firefox.


Welcome to Cayenne!

Sometime a page refresh will make the widget disappear. If that doesn’t work try rebooting the Pi and deleting again.


Same bug here, even after power-cycling the Arduino (not the Pi) and refreshing the page.

I tried with the browsers, Safari and Chrome on macOS Sierra.

Thank you!


I see that your Arduino is offline. I’m not sure what happens in the background but I know changing widgets doesn’t work properly while the device is offline. Can you get it to show up as online and try again?


It is back online now!


Did they disappear?


No, there are still there.


Hi @rei_vilo,

Welcome to the Cayenne commuinty! If you try removing widget while your Arduino is online, it should work. We will be doing UI update for this to create better experience when attempting to remove widget from an Arduino that is offline.