Need help with DS18B20


What dashboard are you using? (Web, iOS, Android)

Web & Android

What OS? (Jessie, Wheezy)


What Model Pi?

Pi 1 B+

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

sorry for my bad english.
I connect DS18B20 to my raspberry pi and my dashboard show this, i just have 1 but it keep add more to my dashboard every 30s and i even can’t remove them.
Help me!


Hi hungtran
That’s a very interesting bug.
What happens if you delete them ?


Are DS18B20 ‘Delete-able’ now ?
~ Andrew


Now i can delete it. I’m try to re-install lastest raspbian but still get that bug.


To delete the widget there is a gear symbol in the top right corner.
I’m using 5 of DS18B20 I didn’t pay much for them so they are being massively produced each with their own address I would check on the widgets address they’re the same.
Possibly faulty chip ?


@4ndy Yes, i did that. I manualy remove about 30 of them yesterday.
But some time i wont let me remove, the button “Remove Sensor” was like unclickable.


I try unplug and plugin the DS18B20 again and it work for about 10 minute or less, and then it show the bug agian.
This is my dashboard right now.


Still want to know from someone…
CAN you delete DS18B20 yet or does system need to be reloaded from scratch ?
I still get this…

There are a few settings in the Pi system I may have a stab at updating / poking with a stick and hacking to see if that works…
~ Andrew


@picaxe Sorry about that.
Some of them ‘delete-able’, some not, i don’t know why.
If i unplug the sensor and plug it in again, it will work for about 10 minutes and that bug show again.
Any advice ?


It’s almost like there is a problem reading the address of the sensor it should have a unique number can u check it hungtran.


Hi picaxe
I’ve been playing around with these censor for a bit and to be honest they work well with cayenne and I’m at the test stage so lots of playing.
When I’ve unpluged the censor its removed it’s self from my dashboard and I’ve only had problems when reconnecting It ,
It sometimes has problems finding the the settings set when I installed it.
If there’s any advice I can give is always power down when making hardware changes.


Thanks. I will try adding and removing them here as I have 4x different makes of Pi and see how the auto install and remove works. Yes I lke the DS18B20 it is a pretty neat device. To see a string of them off one wire bus is pretty amazing.
~ Andrew


@4ndy: I use Putty to SSH to my RPi,
cd to /sys/bus/w1/devices/, and every time i “ls” it show the different address.


@hungtran @picaxe @4ndy DS18B20 not remove-able yet. They are only remove-able if they were not added properly, and are thus not ‘attached’ to a specific slave address. We’ve been focusing on Arduino, once we get Arduino pushed we will do some house-cleaning and get this ability to remove 1-wires out the door. Hang in there!



@hungtran Can you post a pic of your 1-wire setup? The large negative number usually means a disconnection or mis-wiring.



@bestes: I wire my DS18B20 like this picture


Are you using an original DS18B20 sensor? Like this:

I ask because I see another user who uses Chinese made DS18b20 that produced issues.

Also, here is a Cayenne tutorial to reference just in case:

I’m having trouble reproducing your issue but I hope we can work through this!



I bought an waterproof DS18B20 with metal shield cover it, i don’t know what the manufacture is.
I’m from Vietnam so i think the shop sell it for me get it from Chinese.


Can any other pin than Pin 4 be used for Onewire on Cayenne/Raspi? I have a Razberry card on my Pi that may use Pin 4 but certainly sits over the top of it so I cannot use it.


For 1-wire devices, you’ll need to use pin 4 for if trying to display data in Cayenne. This may change in future, but for right now Cayenne will auto discover 1-wire devices connected to Pin 4.