Bug Filed on 04-06-2016: Can't get Cayenne back online

I had Cayenne installed on my Pi3(Jessie/64GB) with a simple project running reasonably happily and I could connect to it using the beta Android app.

The only serious issue was that the Pi3 was running hot - I mean VERY hot - 97 DegC at 5% - way above its safe operating range. So I backed up the SD card and transferred it to a Pi2 B. When I tried to connect to Cayenne from the browser on the Pi or the android app the installation is shown but it is offline.

I returned the card to the Pi3 but no luck - the same thing was now happening on that too. I tried a new card with a clean install of Jessie in the Pi2. When I tried to install Cayenne it just showed the old installation which I couldn’t delete from either the browser or Android.

I don’t want to create a new account so what is the best way of clearing the old instance of Cayenne and installing it afresh on the new card?

Hi Charles,

Hmmm, weird. Never seen this before. Interested to see if this happens again when you do the new install.

You can write a new Raspbian image on the SD card. I would recommend latest version of Jessie

You can then generate a new install code by adding a new Raspberry Pi device from the dashboard. Add Device–>Micro Computer–>Raspberry Pi–>Generate new Raspberry Pi Installer.

Please keep us updated with your progress on this!


You scared me with that comment! Only because I hadn’t checked my RPi3b for temp. I just looked and mine is at 58°C which is very tolerable.

It’s odd that yours was getting hot. Almost like it was overclocked or something like that.

I’m sorry to hear you are having troubles, good luck getting them sorted out!


Hi Benny,

Just to be clear, I wasn’t suggesting that Cayenne was responsible for the high temperatures on the Pi3! I checked this by installing a fresh download of Jessie on a new SD card (after trying for an hour to load it on a duff one of course!). This clean image runs the Pi3 at 85 degrees plus so I’m guessing there is a hardware fault on the board.

I installed the Pi2 as a new device from the dashboard as you suggested. The downloaded installer didn’t seem to work but installing via the Terminal worked fine. From the overview I can see that Cayenne has automatically identified and configured the DS18b20 temperature sensor I have attached. I can see the Pi2 from my Android phone and the best thing is that it is running at a very acceptable 45 Degrees.

The only thing I’m concerned about was why did the original installation “Go bad”? Was it because each installation is locked to specific hardware? If so, is there (or will there be) a mechanism for backing up installations and exporting them to new hardware?

Thanks for your help. I’m off to play ;o)



I’m glad you’re not suffering the overheating issue with your board. As you’ll see from my reply to Benny, it looks as though I may have a faulty one as I hadn’t set any overclocking :o(

At least everything is now running (coolly) on my trusty Pi2!


Hi Charles,

Woohoo, I’m glad this got sorted out. Unfortunately, I’m not sure why the Pi had such a high temperature reading. Although, I did read that a faulty power supply may be the cause of these type of issues.

There will be a feature that will allow you to export the existing setup onto a new installation, yes.

I’ll resolve this issue now, thanks for working with us Charles.


Very sorry to hear that you may have a sick RPi :disappointed_relieved: