Bug Filed on 05-12-2016: Cayenne device gone, cannot re-install

What dashboard are you using? (Web, iOS, Android)
Web - Chrome 50.0.2661.94 m

What OS? (Jessie, Wheezy)

Wheezy Raspbian GNU/Linux 7

What Model Pi?
RasPi 2

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

When I logged into the website yesterday (this was after the new agent was released) one of my three Pi devices was missing from the list of devices. I tried creating a new installer and ran that on the pi but the web site and IOS app do not recognize the device.

I then tried removing Cayenne with the following commands then created a new installer but same affect. The pi is not recognized by the web site nor by my IOS app.

sudo service myDevices stop
sudo service webiopi stop
systemctl disable myDevices <<<< this command was not recognized by the OS
sudo rm -rf /etc/systemd/system/myDevices.service
sudo rm -rf /etc/init.d/myDevices
sudo rm -rf /usr/bin/myDevices
sudo rm -rf /etc/myDevices/

The website shows a screen for the new device with “Pending installation” in the center then the install commands below that.

Checking the processes on the pi for the string “myDevices” shows this:

What do I have to do to add this device back? Please don’t tell me I have to re-install the Linux OS. :frowning:


I just ran the ps -ef command again and it appears that the list of processes is growing. The crontab.sh process has increased from 11 instances to 21 and growing.

Please advise how to resolve this issue.

If systemctl command was not found that makes me think you are not on Jessie, and jessie is the only current supported OS.

That’s correct, I’m not on Jessie. I wish I had known this before I installed it on all my pi’s. :frowning:

Why doesn’t the installer recognize and warn the user during installation that the OS is not supported?

Now what? Do I undo weeks of mods I’ve made to my pi’s to customize them?

How can I uninstall this app?

Which emoji is used for very frustrated and disappointed??


I agree, would be a good thing to warn about. Can’t say I’ve tried to install on Wheezy so I can’t comment on the install process there.

Try this:
Make a backup of /etc/webiopi/ and install Jessie on a new SD card. after you install Cayenne copy your backup of /etc/webiopi/ from your old install and reboot. Check your dashboard to see if your sensors and triggers came through. I’m not 100% this will work, since I have not tried it, but I’m thinking it will.

sudo /etc/myDevices/uninstall/uninstall.sh


Thanks Adam, I’ll try your suggestion regarding webiopi.

The uninstall script doesn’t work. Already tried it.


Do you get errors for the uninstall script? Or does it just not do anything?

I can’t recall. At the moment I’m restoring an old image but I’ll test it again and let you know.

Forgot to mention if you don’t immediately see anything give it 15 minute or so to let everything sync up.