Bug Filed on 05-26-2016: Dashboard doesn't seem to be synced up with Pi

What dashboard are you using? (Web, iOS, Android)

What OS? (Jessie, Wheezy)

What Model Pi?

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

When I push a digital pin button on the dashboard I can see the commands coming through in debug mode, and everything seems to be ok on the Pi, but the dashboard doesn’t update the button. It just gets stuck with the loading circle until I refresh the page.

I get the same thing when deleting a widget. I see the command in debug mode come through but the dashboard is stuck with “Removing…”

Is your computer or Pi on WiFi?


Both are on ethernet

I have had that problem. I tried several browsers and that seems to make a difference.
Best to worst(in my recent experience):
Internet Explorer
Note: sometimes the busy signal lasts so long, you’d think the browser had crashed. Of the different browsers I tried, each took a different amount of time to complete the task. Try waiting for fifteen minutes once and see if the task is completed.

@ats1080s The LED (or whatever is attached to digital input pin) functions properly and turns on right away? I ask because then we know it’s the response from the agent that is taking long time to confirm that the light turned on (thus causing widget to continue to spin).

@jimlynnjulian2 That’s valuable info to know. :slight_smile:

Yep, Hooked up an LED and it turns on/off instantly, dashboard still spins away though. As soon as I refresh the page I can click it again to change state but then it just repeats.

I noticed, and posted elsewhere, that the GPIO page works better, faster than the Overview page. In many instances, going to the GPIO page and pressing a ‘button’ completes the task stuck in a busy loop on the Overviewer page. I’m talking about the dashboard on a browser webpage

@ats1080s Sorry for questions here. So I’ve finally been able to reproduce similar on a Pi, except the widget turns to proper state after maybe 20 - 30 seconds.

Do you have a lot of sensors etc. connected to that Pi? I have 9 1-wire sensors that seems to be slowing down interaction with all Pi events.


Nope, just 2 digital outputs. It actually started working fine a few days after I posted, forgot to post back. Just checked again and still working as I would expect.

Oh yeah… I forgot to tell you… we totally pushed a fix for this :wink: (kidding)

Well, I’ll resolve this for now, let us know if it comes up again and if there’s something out of ordinary that triggered it.


1 Like

Just an eight relay card. I use the audible clicks of relays as a feedback mechanism.