Bug Filed on 06-23-2016: The BMP180 sensor cant be added to the dashboard using an iPhone



I hooked up a BMP180 Sensor to my Raspberry Pi Zero. When I tried to add the sensor to my dashboard using my iPhone, the app said it was added successfully, but the sensor did not show up on the dashboard. I tried several times and showed Dave and Benny, who also tried it.


i am facing same issue.
I tried using iphone and cayenne online dashboard. it says its added successfully but nothing shows on the iphone screen but shows blank graph on online dashboard.
I am using this BMP180 with a Pi I2C shield
I can detect the sensor using sudo i2cdetect -y 1 and i also wrote a python script which works fine. so it means my hardware and sensor is working.


Hey @lance2!

Welcome to the Cayenne community forum. Thanks for posting the issue, we’re going to investigate what happened and see if we can reproduce it. If you end up getting the BMP180 to appear, update us :slight_smile:


Thanks for updating us on this @bhaskar.anil430. We’re investigating.



Hey @lance2,

Can you try using a different power pin? Try using both VIN and the 3v3. Let us know if that fixes it if you can :slight_smile: Also, we just released a new iOS app version so download new version too. Thanks!



It works great! Thanks Benny!