BMP180 -Failed to add the sensor, please re-check your settings. Make sure you selected the correct Channel/Slave Address

Raspberry pi model 3
Web portal

Brand new install following the tutorial for adding the BMP 180 sensor - Receive the error above when trying to add the sensor.

Ran i2cdetect and no results on any address (dashes in all outputs)

Have tried different power from the cobbler and also tried to connect directly to the relevant GPIO pins on the pi motherboard.

Anything else people can suggest?

Hi @woz,

This sounds like some wiring issue, esp. if I2C detect can’t find your sensor. Maybe you can attach a picture of your setup? I think that is best place to start. :slight_smile:


Also - I’ve been having a look on the adafruit forums and I’ve ensured that all of the i2c libraries and tools are installed. Still no joy.

Final move is to buy another BMP180 from Amazon to make sure that it isn’t the component.

Well, if I2C is enabled within Raspbian, AND your wiring is correct, AND you’ve installed the Adafruit library- AND the Adafruit can’t see the I2C device, -then it’s dead…

I’d reinstall a fresh Raspbian and get that all setup and updated, enable your expanded memory and your I/O options, then install your I2C utilities. Really, if the Adafruit utility can’t see the I2C @ 0x40 (the default), it could be software, hardware, firmware…you name it.

Going off of what @HighTech said, you might also want to check the ribbon cable that’s attached to the Pi-side of things. Make sure it is not attached the wrong way. If I told you’d I’ve never done this I’d be lying!

Keep us posted with your progress, BMP180 is a super easy sensor to add to Cayenne, assuming all wiring and the hardware itself works of course.


Ya…what he said

It’s a very good call, I am a total beginner and not above putting things in upside down! The ribbon cable from the image above - The black wire on the right of the image is attached to the end of the GPIO furthest away from the USB ports. If you look at the image on this link ( the back would go to the top of the picture.

I’m very happy to install a fresh image, I was using the image which came with the pi kit. Could somebody who has a working system perhaps recommend a good download for an image with the right components pre-installed?

*/s back / black

Raspbian Jessie is the image you’ll want.


Update - The good news is that I found a schoolboy error - I found a pictorial tutorial which led me to understand that Vcc is volts in NOT 3.3.

With that fixed I can now add the component without the error shown in the subject but i2cdetect still doesn’t show anything.

So it successfully added in Cayenne?


It added but it’s not showing any data.

and another update - I’ve purchased a second sensor and still getting the same problem. I’m going to blow away the OS on the pi and try a fresh install

@woz I know you had that issue with Remote Access which was likely due to the OS re-install, but: curious if, ignoring that, you had any better luck with the BMP180?

If the installation not work. Try to add manually the i2c configuration. Follow this guide to add i2c on your Raspberry Pi.

After this you can see the slave address that you must add to Cayenne installation page. Try to write on terminal of Raspberry Pi:

sudo apt-get update

sudo apt-get install i2c-tools

sudo i2cdetect -y 1

Now you can see the address. The address is ever 40.

Hello all, I will now be admitting to another schoolboy error here. I’ve got it working and reporting correctly through my phone based console.

The trick was that the señor provided needed to be carefully soldered onto the to attach to the breadboard. Once I had done that it began to work :slight_smile:

So I have learned a valuable lesson which is that good soldering is critical on projects.

See below. Haven’t done the OS reinstall yet but the soldering iron fixed this issue.

Mine was working until I added a DS18B20 and installed the Adafruit library, now I am being asked for a channel but there is no way to enter it…

Hello team,

I´m having the same problem with this sensor but using the command sudo i2cdetected -y 1 the sensor was detected.

Other point is, how can I change Fahrenheit to Celsius?

Below the pictures:

Hello, worked now… I reset my dashboard and add again the sensor and worked