DS18B20 Temp sensor/Cayenne dashboard problems


I have the DS18B20 temp sensor hooked up and running. It’s also reading out to an LCD display.
The problem is that it doesn’t show on my iPhone. I have reset the dashboard many times. If I add the same sensor again it will show up once on the phone and twice on the web dashboard. I don’t get it.

Is there a problem with the website?


Hi again @muzf.corp,

You can disregard my response to your same issue in the other thread, since I can see here that you’ve tried resetting the dashboard and that’s not doing it. And no, it should not be necessary to ever add the widget a 2nd time on the phone side. Any changes made on the web should reflect on the phone, and vice versa.

While we’ve had some issues with the DS18B20 widget recently, we believe them to be fixed in the current website code. It is possible that our recent changes created a new bug with this widget. This is a bit of a guess, but could you try getting your (web) dashboard the way you’d like it (with just a single DS18B20 widget), then uninstall and re-install the Cayenne iOS app to force a refresh on the iPhone side?

If it’s still not displaying, I’d be interested in requesting your credentials for a short period of time (via PM). You can reset your password before (and after) sharing anything via this form if desired: http://www.cayenne-mydevices.com/forgot. This is of course completely your call – if you’re not comfortable sharing that, no worries. The idea is that it would be easier for our development team to figure out any possible bugs by reproducing on our test iPhones viewing your same dashboard.


ok, give me a day or two and I’ll have time again to address this with you.


PM sent. Thanks.


Also, the update speed of the dashboard is very slow. Like, crazy slow.


So we are reproducing a lot of this with your credentials (dashboard slowness), the widgets sometimes populating on iOS and sometimes not.

A couple more questions for you.

  1. What is your connection from the Pi to the internet? Ethernet? Wifi? something else?

  2. I’m seeing 2 DS18B20 sensors on Cayenne. They seem to be passing different values so I imagine they are unique, but I want to make sure you actually have 2 sensors (and no more) hooked up here since you’ve mentioned duplication. Which digital pins on the Pi are they wired to?



Two sensors are hooked up. GPIO4.
The are in different heights, one up and one down, hence the different temps.

Connection is RJ45 Ethernet


Do you use an resistor in the circuite to connect the sensors to the 1-wire port on the pi? Like here: https://www.einplatinencomputer.com/wp-content/uploads/2015/01/ds1820.png

Maybe you can show us your circuit :slight_smile:


Hey again muzf,

Thanks for the additional info. Unfortunately I’m not sure I have a solid idea of whats going on yet – as I said I can reproduce the general flakiness you are seeing when logged into your account, but not when creating the same setup on our end.

I do see that the RAM usage on your Pi is pretty close to 100%, and that you’re running more processes than my test setup. Is it possible anything else is running on the Pi that could be slowing it down? It may be worth trying a good old fashioned reboot (if you have not yet) to see if that improves things, even if temporarily.

Can I ask if for the current widgets, did you let Cayenne create them itself? For most sensor types, it’s necessary to go through the add widget process, but with DS18B20 (and other ‘1 wire’ sensors), the idea is that you should be able to wire them up to GPIO 4 with the the Pi powered off, then when you power it back on, they should be automatically added to the Cayenne Dashboard. If you’re creating the widgets by hand while they are also connected to GPIO4, I could see that potentially creating some odd situation.

So if the above doesn’t work, it may be worthwhile to:

  1. Disconnect them from the Pi (just pulling the data wire from GPIO 4 should be sufficient, no need to re-wire)
  2. Power off the Pi, then Reset your Dashboard once more (I know, but just for the blank slate)
  3. Reconnect them to GPIO 4
  4. Power back on the Pi, then view your Cayenne dashboard, where the widgets should be automatically recreated as soon as we detect them.

Failing even that, maybe we should take a look at the wiring as tooony suggested. I have to assume you have it mostly if not 100% correct though since we’re getting data from the sensors, even if occasionally. I’m not sure if the lack of a resistor (or the incorrect resistor) would cause intermittent behavior like this.


Also worth noting, the widgets disappear after exiting out of the app and re-opening the next day. I have to wait like about 5 minutes for them to pop up again.

iPhone 5S Latest OS.


I have also noticed there is no history available for these sensors… Can auto detect but can’t keep the history?
Why is that?
Also, how long will this beta last for as I want to run a new business idea using some of these services but only when it’s stable.


I seem to have the same problems with a Pi B+, i have 4 DS18B20 sensors connected but the dashboard is full of sensors. Also no history indeed. This worked before but stopped a few days ago.
I also have an arduino uno running 1 day and there i can see te DS sensor with history all ok.

I have already removed the PI from the dashboard and reinstalled it, but no effect.
See screenshot of google chrome.


Thanks for attaching the screen shots! I PM’d you :slight_smile: I’ve seen this bug come up before, and we pushed a fix. Looks like it came back.



No problem, i pm’d you back.


Hi B,

I am facing the same issue with a serial USB connection. I have two flow meters and two temperature sensors DS18B20 connected to my circuit at the moment, with an LCD screen. The temperature sensors are working absolutely fine as I can see the display on the LCD, but it is not showing anything on my channel. Please find the program in the attachment and the screenshot as well

Can you please tell me what is it that I am doing wrong ? Or is there a problem with the channel?Stephans device with 3 temp sensors 3 flow meters and 3 pushbutton and lcd.txt (16.7 KB)


Hi @pal.shruti30,

At first glace all of that code looks good. Can you show us your serial monitor output?


Hi RSiegel,

I have no serial output as previously it interfered with my output on cayenne. So I was advised to comment it out.

Therefore, at the moment, I do not have any serial output on my arduino whatsoever, just the LCD display showing the values.


Ah yes, I see now that you mentioned using a serial USB connection, so no serial monitor output, that’s correct.

But now that I’m looking at your sketch again, that

#define CAYENNE_PRINT Serial

is not commented out, and

Serial.begin(9600); is present in your setup() function, neither of which I would expect in a sketch using our Serial USB Connection code to connect to Cayenne.

Can you try commenting both of these out to see if this improves things at all?


Unfortunately, it still does not help. Resubmitting the changed program and the new output in my LCD and my channel snapshot. Stephans device with 3 temp sensors 3 flow meters and 3 pushbutton and lcd.txt (16.7 KB)


Hello, Just wanted to follow up on my query. Would be great if you could help me.

Thank you.