Bug Filed on 12-24-2015: Relay Sensor not added: Failure

1. What OS? (Wheezy or Jessie)

2. What class/size SD card? (ex. class 10 16gb)

3. What Model Pi? (A+, A, B+, B, Pi2)

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

Got a screen shot for you this time :smile:

Please fix the following errors:
Failed to add the sensor, please re-check your settings. Make sure you selected the correct Channel/Slave Address.

My guess is if I reboot the pi and try to re-add it will work just fine. Not sure what this bug is?

It appears as though I can’t get this relay added even after a reboot. I let this screen sit for about 15 mins then refreshed and tried to add it again and now I get he same error message as my first post. Any suggestions?

I can also add to this that I am receiving no packet loss (ping stats below - I’m assuming these are your servers) and if I go to the GPIO tab I can turn the relay on by changing the mode to OUT, however, it’s very hit or miss trying to get it to toggle because more than half the time I get this error: Error sending command

— ping statistics —
41 packets transmitted, 41 received, 0% packet loss, time 40016ms
rtt min/avg/max/mdev = 101.396/118.108/662.448/86.076 ms

— ping statistics —
31 packets transmitted, 31 received, 0% packet loss, time 30046ms
rtt min/avg/max/mdev = 102.093/137.100/1058.662/168.264 ms, pipe 2

Above is consistent with experience here…
Adding DI works 10% and only once / first time and can not add any more
Adding DO the last few days has been < 5% success
~ Andrew


@picaxe @ats1080s we will look into this guys, thanks so much for thorough input.

No problem. If you need anything from me just post back or send an email. I’ll add the rest of my sensors after the adding process is sorted out.

Got some rainy days here and I’m itching to do some tinkering. Any progress on these issues?

Hey Adam,

Are you sure the relay is wired up correctly? We were able to successfully add a relay and turn on an LED light that was connected.

Although, to do the above we added a light switch widget to the GPIO pin that the relay was connected to…so the relay was really just a pass for the light I guess…if that makes sense.

Think you could email me your account info? Might help if we can debug your Pi and take a look around.


I get the same error trying to add a light switch. I will email my login info now.

I should also add that I know the relay is hooked up correctly since on rare occasions I can toggle it with the GPIO tab on the dashboard.

Just to clarify my logic… The Pi GPIO physical pins do not interact with LED’s or voltage contacts so in theory should be very simple to add.
BUT… Seems to me that adding anything DI or DO the issue is just completing the Dashboard dialogue as it stalls a few different ways:

  • 1/. Things stay half bright lit so can’t complete
  • 2/. The 'in progress, please wait, circulating icon just stays there
  • 3/. A red you have done something wrong randomly / inconsistently comes up
  • 4/. Communications lost or link failure ( occasionally ) so this is understandable…

~ Andrew

Model RPI B+
OS rasbian wheezy
SD card - Sandisk 8GB class 4

I seem to have the same problem trying to add a relay or light switch.
When I’m trying to add the relay or the lightswitch I cannot choose the channel to which it is connected.
Already tried rebooting several times that does not seem to work eather.
I know that the hardware is correctly installed because it works fine when I’m using webiopi.


Hi Mike,

Are you using a wifi dongle on your Pi?



No I use the rj45 connection.



Think you could email me your login information so my team can ‘look under the hood’? bestes@mydevices.com


Back from the beach… I have tried to ad generic OP just now on Pi ‘C4’ and performance issue looks about the same at the moment. Realise you are migrating servers etc ? But happy to set try anything out now I am free for a few weeks standing by beside the 2x Pi 2 sitting on bench / table top test here.

Re the above issue I can test wifi dongle vs cable to router. Also happy to pass / share login details and or leave it set up so you can set up tests, zero in or give me something to check out this end. Test ? I suggest activate an OP connected to an IP E.g. suggest GPIO12 set up as an OP be looped directly to GPIO21 set up as an IP. This way once it is debugged you can do a speed / performance / response time thing.

Sure am looking forward to some projects and getting the graph threshold / data log feature going.

Will the threshold / alarm be able to activate a generic OP GPIO header pin to raise a hardware alarm etc ?

~ Andrew

Resolving this…the issue was that Cayenne was installed on top of WebIOPI.