Bug Filed on 01-07-2016: Adding Generic Digital InPut and Generic OutPut

1. What OS? (Wheezy or Jessie)


2. What class/size SD card? (ex. class 10 16gb)

8g class 10

3. What Model Pi? (A+, A, B+, B, Pi2)

Pi 2

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.


I would really like to know what I am doing wrong or if the adding digital IP / OP from the physical Pi GPIO pins feature is enabled ?

I have been trying for a few weeks now and it was sort of working initially then IP only sometimes worked, Now I can not add IP or OP.


~ Andrew


We need some info before helping you with all this problem:

  1. What class of IP/OP are you adding?
  2. Is the added sensor available on the dashboard or is it failing right away?
  3. Can you provide content from the files:
    This is the actual setup that you have.

If the sensor is not available than we need to enable debug on the pi and do a step by step add.

1/. I am trying to add a generic IP or OP device such as a hard wired switch between the pins on the Pi GPIO header 3.3 volts via a resistor to any spare IP pin OR LED’s resistor, simple piezo buzzer connected via a resistor to -ve.

I am not using a ‘Device’ in the sense of a breakout board, interface board, i2C or module or chip.

2/. The sensor or OP device appears to be available and the steps of Add Device = OK
Select Generic OP = OK
Select Pi ( I have 2x Pi2) = OK
Select Widget (button) = OK
Choose Icon (light) = OK
Select GPIO = Select Integrated GPIO (only option available)
Select Channel = OK (heaps to choose from)
Select e.g. Channel 12 = OK
Click “Add Sensor” =

Then a few seconds later… the Sensor Added Failure…" messages disappears to…

(I just noted that a special feature that makes me look dumb is… as I was making up the above intermediate screen capture I clicked the final “Add Sensor” button a 2nd time and it went through okay. (30 sends after the first error message came up)
But I have not been able to repeat this feature (just cycled power to the Pi)

0000049e1b6d = DS18B20 slave:28-0000049e1b6d
DigitalInput21 = DigitalSensor gpio:GPIO channel:21
000004215bba = DS18B20 slave:28-000004215bba
0000019e5d79 = DS18B20 slave:28-0000019e5d79
000001493f13 = DS18B20 slave:28-000001493f13
0000049e2b2b = DS18B20 slave:28-0000049e2b2b

InviteCode = dx5m6ixxxx
Initialized = true
Version =
Environment = live
InviteCode = 4xp2ocxxxx
Initialized = true
Version =
Environment = live

Hope this helps.

~ Andrew

Hello Andrew,

Ok so it looks we need some debug logs.
Can you provide access to your account/pi?
Or we can debug in TeamViewer session.

Let me know!


Please contact direct e-mail to Andrew Hornblow
picaxe(at)clear.net.nz for my login and pwerd. I would like to see if you can set anything up for me or point out what I am missing…

On BOTH Pi at present I have several generic IO devices connected directly to both my Pi GPIO pins. E.g. LED’s and Switches. I have also linked Channel 12 directly to Channel 21. This is a good way to remote test this sort of system. If Channel 12 is made a Generic OP then you can toggle it to turn the Pin ON:OFF HI:LO and watch Channel 21 input go ON:OFF HI:LO etc.

Channel 24 has a small piezo buzzer on it so if you get it working please set it high or have fun beeping it for me. PLEASE try it

~ Andrew

Hi Andrew,

Do you have WebIOPI installed on this pi?


Do you mean did I install WebIOPi ‘as well’ or first ?
This is a clean single install of Cayenne with nothing else.
I did not install anything prior to running the Cayenne install or after it.

I have remote logged into the Cayenne installed WebIOPi to test things out and this works about as expected ‘instant’ response and control of IP/OP Hi/Lo

When setting up both Pi I made 2x clean fresh setups:
SD Format > Rasparian > Update > Upgrade > Cayenne Install

After all these weeks of no progress should I repeat a clean install ? I can do this easily on one of the 2x Pi 2 I have set up.

Happy to pass you login and pwerd via a separate e-mail direct to me

~ Andrew

I meant Cayenne with nothing else. I don’t usually do the update / upgrade prior to installing Cayenne, I wouldn’t think doing so would cause any issues though.

It’s just weird that you are still having OP issues that we can’t seem to reproduce on our end. I’ll send an email direct to you in a second here.

It’s just weird that you keep having issues when I can’t seem to reproduce. Hoping we can get past this soon!

Happy to test anything out.

Could have something to do with the number of hops between open mesh boxes I use to get the LAN to where I have things set up.

I will put on Pi-2 direct onto the router beside the copper connection to see if any difference…

I did manage to add a digital output to the Pi pins on one Pi the other day.

As previous a video / screen capture of sequence to set up a generic and ‘expected performance’ would be good. There is a pretty good chance I am doing things a wrong way about…

It just the add device works some times / very occasionally.

Also… Activating an OP when i do get it working most times is pretty prompt / good but turning it off again often requires jumping out to the GPIO tab to be able to regain attention and turn it off.

Every chance that there is something letting lost in all the hops it takes to and from you guys to and from NZ which would be a heck of a different than just in the same building / city as the server ?

~ Andrew

Ongoing monitoring and observations:

  • ‘Slightly better’ success rate at adding generic IO
  • Currently toggling an OP works ~ 50% of the time
  • Response rate of a successful toggle is instant to 10 seconds
  • Toggling an OP usually works the first time when making tests
  • Dashboard most of the time shows ‘waiting’ animated icon for > 1 minute
  • Dashboard screen shows error messages ~ 30% of time on failure to toggle
  • GPIO Tab screen shows an error message ~%99 of the time
  • Error messages come up within 5 to 10 seconds if a failure
    Have tried this on various OS and cable and wifi lan this end seems to make little difference
    ~ Andrew

Not letting this one go…
Okay so following phase one of the Video (thanks) using just the GPIO Tab screen of your video and the pre-twiddle with GP 17, 27 and 22

On the Pi2 “C4” wired LAN to router directly
Step 1: Toggle IP > OP

  • Randomly one or all three will eventually change state after clicking each ‘IP’ button one after the other rapidly = click, click click
  • It takes about 7 to 10 attempts (sets of clicks) to get all three channels configured as OP
  • One or two or sometimes (jackpot) all three change state

The individual per channel reliability / success rate is < 50% if I just sit on one channel and try and toggle it between IP and OP

Step 2: Toggle ON:OFF
Pretty much same as above I.e. takes about 7 to 10 goes to get three pins to change state and < 50% success rate at changing an output state to Hi / Low

As above there are ‘pretty consistent’ friendly pink “Error sending command” message comes up sometimes almost instantly as I click and sometimes half way to timeout (10 seconds) and sometimes when it has given up (after 10 seconds.

On the Pi2 “F1” via OM network and a 2nd router
Okay… messy I know but by pushing the limits this may indicate where problems could exist and help track this bug…
Step 1: Toggle IP > OP

  • Repeating same tests as above it takes > 30 - 50 click attempts to get any of the IP pins to change to an OP

So if ‘feels’ like from here the software somewhere end to end (Pi <> Cayenne) may be relying on a faster turnaround than available here

Or relying on a single event over a potentially long path where the response could fall outside of the ‘expected’ total time of the path.

( Re flashing card on Pi2- C1 and total scratch clean re-install )

~ Andrew

Almost fixed… I was going by some advice I read that updates and fixes were automatic and it turns out that a deep, fresh install or rasparian and re-install has almost cleared this bug:

Format Card
Install rasparian
sudo Raspi-config (memory + local settings)
sudo apt-get update
sudo apt-get upgrade
Generate installer

Done :slight_smile:
At present:

  • GPIO Tab screen faultless on one or multi channel IO Toggle setup and Hi:Lo toggle testing 99.9% with up to 10 second response time

  • Dashboard Tab installing Generic IP / OP 100%

  • Multi DS18B20 auto discovered and installed

  • Toggling of Dashboard OP is 90% reliable and some times sits on the waiting NoGo icon for ages with no OP state change or error message

Shall go and give the other Pi the same medicine (gut it and re-install)

~ Andrew

Hi Andrew,

This is great news, way to go! We’re looking into issues where the agent does not automatically update. Sorry for the troubles, I’m just glad you got things working now. I suspect this has vastly improved the usability of Cayenne for you.