Cannot add device after again removing it

  • Device & model you are using - Raspberry Pi Zero W running Buster reading a temperature sensor

  • What dashboard are you using? iOS iPhone and iPad

  • Please describe the bug / issue as detailed as possible. The dashboard had stopped showing temperature changes. Decided to remove and reinstate device. Remove worked OK, or seemed to. Adding again never seems to complete and leaves various files behind.

pi@DDhomepi3:~ $ ls
cayenne.err Dropbox-Uploader Pictures Videos
cayenne.out Music Programs
Desktop myDevices Public
Documents myDevices.tar.gz python_games Scripts
Downloads oldconffiles RPi_Cam_Web_Interface Templates


what error do you get during the installation if you are trying to install using the terminal.

I tried from the app. It never completed.

I tried running from the myDevices folder and got many lines of output that looked good, but then some I cannot fully recall about “not authorised”.

Is there some action I can take to clean up and start again?


PS - I am now remote from the device so I can only access it via VNC and terminal via that. Ideally I need actions I can carry out by that route.

on your pi terminal /etc/myDevices/uninstall/ to uninstall pi agent. Next open cayenne dashboard on a web browser and navigate to Add new ---> Devices/widgets ---> raspberry pi from the option 2 run the lines in the pi terminal. this will install the cayenne pi agent on to your raspberry pi. if there are any issue reported while installing in the pi terminal then share it here.

Thanks very much Shramik! Worked perfectly and now up and running again.