Can't login on Google pixel , works fine on PC and ISO


Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)

  • What dashboard are you using? (Web, iOS, Android)

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!


I can’t see my projects on the app when using my android phone and there is no way to sign in , all works fine in ISO and my PC , tried reinstalling and accessing through chrome and Firefox ,but it always directs me back to the app with no change.


Hi @marto61,

I saw your email about this before this post and sent you some troubleshooting steps to try. Please feel free to reply either here or there to let me know if they worked or not.

Just to be clear, is the issue that you can’t login to the app (you are stuck on the “Create my free account”/“Sign in to my Account” page), or are you advancing past that and seeing something else?


Hi , Thanks for the reply.
The problem I’m having is that when I open the app I see the page with the projects ,devices and community options , but at the top of the page is just a blank circle where my account info would be . if I click on projects I just get a screen with the projects heading and a green circle turning but no projects loads, if I try to add a project I can select hardware and connection type but it never progresses from there and doesn’t issue a token.
It appears that I am logged as far as accessing the community page but that’s the only one.
It all works as it should with my iPhone ,IPad and PC but not my Google Pixel Android phone.
I have checked that the app is up to date and tried uninstalling and reinstalling the app many times.
Regards Dave Martin


Hi , just figured out the problem and its now working , even though I was removing and reinstalling the app I still needed to go into the app settings and clear all the stored data and cache.

it now works fine , still getting used to Android after years of IOS.
Thanks for your help
regards D MartinCayenne cache


Glad that these steps were about to sort the problem for you. You shouldn’t have to to this often, however, so please let us know if the behavior returns even if you do now have a way to clear it.