Dashboard malfunction, Projects erased


#1

Hi, I’m using Cayenne with Raspi 1 B+ to control some relays and sensors, after updating to pi agent 2.0, a while ago, it was working better, less offline problems
Yesterday I wanted to turn off a relay with cayenne app in android, but to enter, it ask me to enter login again, when normally it’s saved. Then inside was empty, no devices, no projects. After a while I open app again and some basic RPI information was on dashboard but still no projects, and today I see some elements but with other icons and still no projects. GPIO tab is working very unstable, most I/O’s are empty, some of them as IN when they are OUT, a 1-W sensor is Offline, my projects are deleted. In both, app and web.
Can you tell me what’s happend?


#2

Hi @stefschin we pushed a big backend update and there have been a few teething issues, but mostly resolved now.

Projects were never “erased” they just weren’t fully migrated. You should be seeing them now on your dashboard. You may notice some sporadic login issues within the next hour or so, but we are resolving them right now.


#3

Still lots of broken dashboards and devices reporting offline - any further updates?


#4

@tim2 are you talking about dashboards and devices on your account? Web dashboard? On our end it seems everything looks normal again. Can you PM me your account email address?


#5

Most my dashboards are working but the widgets are still all changed, in a totally random fashion. Some gauges are now a simple 4 digit display, other displays are now graphs or gauges. Everyone is something different than it was.
One dash says it’s been off-line for 20 minutes, but if you look at the “details & chart” for a widget it is updated. Strange.


#6

I sent you a PM.


#7

Update:

My projects are back.

My devices are there, but they are a full scramble of gauges and
graphs, where I used to have values.

REST API not working.

Graphs now looking strange - the “h” for hour works, but the day, week, 1mo, etc show with just a bit of data on the right, as follows

The data is there, and will expand with a roll of the mouse.


#8

What is the status of the Web update.
My dashboard widgets are still all wrong and the values not updating after the first login.
I only have one device.


#9

@stefschin @tim2 @margettepv @snowy can you provide the following information:
Dashboard: Web or App
Device: Pi or Arduino.
Code:
Dashboard screenshots of the bug:

Above information can help us to reproduce the bug at our end and help in solving the issue.


#10

Dashboard: both Web and App shows same problem
Device: ESP32 with Arduino IDE
Code: working fine before the Web upgrade.
My code updates values to Cayenne every 20 Sec but are not showing up on dashboard widgets, which are all showing wrong Icon’s ect .


#11

issue: button widget do not display properly (blank icon)and values are loading for ResetCount, Watering time in minutes, interrupt Co ?
Are all those button widgets added from generic actuator or using custom button widgets?


#12

Yes values are loading for ResetCount, Channel 0,Wifi disconnects,Hours,Minutes interrupt Co But values are not being updated every 20sec as they should be.
"SelectedRx, Pump Toggle, Start Watering should be Button Actuators.
The rest are displaying digital input states from ESP
The Button Actuators do actually work as shown on the ESP.

Ok this is what ESP sends
CAYENNE_OUT(0)
{
if (millis() - lastMillis > 20000)
{ lastMillis = millis();
Cayenne.virtualWrite(0, millis());
Cayenne.virtualWrite(1, RTC.minute());
Cayenne.virtualWrite(4, localhour);
Cayenne.virtualWrite(3, digitalRead(pumpstate), TYPE_DIGITAL_SENSOR, UNIT_DIGITAL);
Cayenne.virtualWrite(5, (numberOfInterrupts));
Cayenne.virtualWrite(12, (wifirecount));
Cayenne.virtualWrite(6, (tanklow), TYPE_DIGITAL_SENSOR, UNIT_DIGITAL);
Cayenne.virtualWrite(7, (tankfull), TYPE_DIGITAL_SENSOR, UNIT_DIGITAL);
Cayenne.virtualWrite(8, (batlow), TYPE_DIGITAL_SENSOR, UNIT_DIGITAL);
Cayenne.virtualWrite(9, (solon), TYPE_DIGITAL_SENSOR, UNIT_DIGITAL);
Cayenne.virtualWrite(10, (solshort), TYPE_DIGITAL_SENSOR, UNIT_DIGITAL);
Cayenne.virtualWrite(11, (rain), TYPE_DIGITAL_SENSOR, UNIT_DIGITAL);
Cayenne.virtualWrite(14, (resetcount));
Serial.print(".");


#13

CAn you change:

to

CAYENNE_OUT_DEFAULT()
{

Can you delete the widgets which are not uploading data? Upload the code, which will add new temporary green widget . Add them and see if they work now,


#14

@snowy @jameszahary Please PM me your email of your account.


#15

Hi,

This morning my Projects are back, widgets are working again and GPIO tab has data again. I just have to change icons, reload DHT22 code and make a full test. I’m at work right now and Pi is at home.

Dashboard: Web and App
Device: Pi 1 B+
Code: DHT22 sensor

Dashboard screenshots of the bug:

update: GPIO screen from app is almost empty too

Thanks for your help


#16

what is the bug in the dashboard screenshot you shared?
Also, the code you are using is of cayenne MQTT python.
can you PM me your account email id, if the issue still persists.


#17

I send you my account and update my post with app bug, on dashboard screenshot just left to change icons


#18

thank you. we will look into the issue.


#19

@shramiksalgaonkar @acedeno
From what I can tell everything is back to normal, or better! Dashboards have returned to their previous state, and as an added bonus, triggers are now working.
THANK YOU Cayenne team!!
John


#20

Great to know! Yes, this was a big back-end update, things should work more efficient now.