Can't Login

I realize this is off topic but I need help with my pi.

Rpi2 mod B
latest jessy os

If anyone has a clue as to why my Pi has suddenly gotten stuck in a login loop as in , login is accepted appears to be going to the desktop the loops back to the login screen. i even tried the wrong user/pw and it says incorrect so it appears to accept the 2 users and pw satisfactorily. I change the pw in terminal following instructions at

I also tried installing on a brand new sd card from samsung. windows kept saying problem with sd card but drag and drop worked fine and then on boot-up I get the raspberry screen and a message saying “waiting sd card(partitions setting)” left it that way for hours and the message never stops.

I am befuddled :confounded:

so now I have gotten a fresh sd card install and installed tempurature sensors read but labels are missing. I checked the mac address against the ip address and that show up in the dhcp list in the router. but, my buttons no longer worked on ios, tried restarting ios device and now cayenne app can’t find the Rpi. On the web browser the button have alerts on each “unreachable” and all analog inputs reading 0 now even tho 3.3v is present. cpu temp magically re-appeared.

Furthermore the buttons, extensions and analog input graph are missing.

Hey @wmontg5988

On the web side, does Cayenne even see the Pi as online? I’m thinking with the reflash/reinstall we may have assigned a different unique identifier to the Pi, not realizing it was the same device.

If that’s the case, it may be easiest to just remove the device from the web dashboard by clicking the settings gear in the upper right, then Configure > Remove device. Once removed, you can re-add it via either the command line options or the iOS app (presuming the iOS app can see the device when you search by IP)

hey @rsiegel

Just followed your recommendation and I got back on track. I have lost the buttons but those were easy enough just have to go associate them with the triggers again and there’s bunch of them.

Thanks for your help

Cool glad to hear it! I should have warned that this would wipe previous widgets for that device, glad it wasn’t too terrible to set back up.

At least the DS18B20’s stuck around :smile:

Hah, yes, they are ‘1 wire’ sensors that allow us the ability to detect them and create the widgets automatically (so long as they are wired to GPIO 4 on the Pi). Wouldn’t it be nice if all the sensors worked that way? :slight_smile:

1 Like

Getting difficult to stay on top of all the new developments-
things are changing so rapidly!

If you trust Wikipedia (we’re not writing academic papers here :slight_smile: ) you can read a pretty solid overview of the tech here: 1-Wire - Wikipedia