Cant re-add device after deleting. "Conflict" error

I messed up adding my device so deleted it to re-add, but when trying to add it back in I get an error “Conflict”.
Searching on the error has found that the device DevEUI even though deleted is still cached, and the cache is cleared on a random and unpredictable times. But what timeframe are we expecting? It has been 2 or 3 days now and this post here suggests that 90minutes might be enough normally Waiting time after delete a device to add it again?

can you share your DevEUI.

DevEUI is [redacted]

I have just tried again with the same error.
This is a loan device that I was given for testing. Im wondering now if the last person to tinker with it had it setup and that is what is preventing me from doing so.

this device is register to cayenne hence the issue of conflict.


Cheers, that is the data it should be sending.
So it is on someone elses account then? How do I get it on my dashboard? Do I have to find who had it last and ask them to remove it or is there another way?

sorry, but we cant help you with it as the DevEUI belongs to someone.

All good mate. Now I at least know what is going on.
The device was apparently last used August 2019. So not sure who had it but we will see how we go, and then I assume 24 hours is normally plenty of time after then delete it before I can add it?