Cayenne doesn't show GPIO pins

I had webIOPi working on Raspbian Wheezy and updated and upgraded raspbian so now WebIOPi doesn’t work. So I installed Cayenne. I am connected and the services started, but on the Dashboard the GPIO tab is blank excpet for the header.

Is this becasue Cayenne didn’t cleanup the old WebIOPi during installation, or becasue I am using an old Raspberry Pi

IP Address (wlan0)
Agent Version
Computer Make Element14/Premier Farnell
Computer Model Model B
OS Name raspbian
OS Version 8
OS Build debian
OS Architecture 0002

Thanks for any help.

Possible solutions: I don’t know which one worked!
Shutdown the R-Pi and came back to it this morning and the GPIO pins are visible and I can control them.

OR: I deleted the /etc/webiopi/config file from my previous life of WebIOPi.

It works now.

Hi @petermerchant,

Glad to hear you solved the issue.


Yes, there are some compatibility issues between webiopi and Cayenne. Glad you got it figured out!

I have given up on Cayenne, It needs Internet access to work and I want to work in an Ad-hoc network, and also the pins labelled SPI cannot easily for this user be made to function as GPIO.

I have discovered Flask and am pleased with this.

Good luck to all Cayenne users.

Peter M.

1 Like