Device offline in cayenne


#1

Hello everyone.
In recent days has had the disadvantage of displaying the devices (Raspberry pi 3) in the panel.
They are suddenly out of line. I have checked that there are no Internet communication problems, but after restarting rasbian, they appear again as available in the panel, but soon the incident is repeated.
Thank you in advance for giving me a hand to solve this problem.


Devices are offline, but still following schedules
#2

Hi @riegosg, are these Pis connected via the MQTT or the Cayenne Pi Agent software?


#3

Thanks for your answer.
I’m sorry I’m new to this. After Add device Pis I execute the procedure of the site;

OPTION 2:
Terminal / SSH

To download and install myDevices Cayenne on your Pi, use the Terminal on your Pi or SSH. Run the following commands:

wget https://cayenne.mydevices.com/dl/rpi_xxxxxx.sh
sudo bash rpi_xxxxx.sh -v


#4

Can you report the version of the Kernel, also, are they offline and the last package message clock is the time that they are offline for, or the widgets are still updating, but there is offline message?


#5

Hi @riegosg,

I edited out the invite code on the Pi links you posted as these are generated on a per-Pi basis and are private to your account.

Can I ask if you generated a new download link for each of the Pis that you installed via that ‘Option 2’ method? If you shared the same invite code (the part which I replaced with xxxxx in your links above) between multiple Pis I could see strange behavior occurring.


#6

Hi @rsiegel,

Thanks for your answer.
I had an incident with raspberry PI at different times. So, replace the raspberry Pi with a new one and put the same SD card. To my surprise these were left offline.

Reinstall the agent with the same code and as it does not work generate a new one. So the answer is yes. yes.
I take and consult. What would be the recommendation for this type of case?

Before:

Now:

Sdos.


#7

Hi @ognqn.chikov

root@CONTROL1:/home/pi# cat /etc/*-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
root@CONTROL1:/home/pi# uname -mrs
Linux 4.4.34-v7+ armv7l
root@CONTROL1:/home/pi#

From already thank you very much for your help. I really need to solve it.


#8

This does not look like the kernel issue, and you have the expected kernel (4.4) anyway.

Could you share with me via private message the output from cat /etc/myDevices/AppSettings.ini on both the online Pi (#2) and the offline PI (#1 in your screenshot). I say via private message because this file contains your private invite code.


#9

@riegosg, thank you for the PM with the AppSettings.ini information. It does not look like that reveals any hints, the differences in the UpdateProgress section are due to the age of install and not connected to this online/offline problem you’re having.

Are both Pis on the same network? If not, you may want to check that port 8181 is open on both as we need that to connect to Cayenne and monitor online/offline status. Here is a post that has a lot of items you can check on the problem Pi to see why it might be showing as offline to Cayenne.


#10

Hi. I’m with same or similar problem since some days ago, Cayenne going offline with no reason. If I test ports using Python commands they are ok, just the Cayenne dashboard get halted, saying the device is offline since some time.
This happened first time some days ago when I used “sudo apt-get update” and “sudo apt-get upgrade”, as Cayenne stopped working at all I just restored last SD image, but since then there was no new updates on RPi.
UPDATED: today I can’t reach Cayenne using Android app, but modules were working normally because a PIR motion that I’ve just installed yesterday was ok (led turning on and off on movement). So I tried desktop dashboard, no success, and when I enter it, says "last know status:a minute ago, as if it halts right when you access it.


Any ideas? Thanks in advance.


#11

@riegosg @aicraga,

Thanks for reporting this issue. I now have a couple of Pis on my network with the same behavior (and some that are not). We are using them to investigate and figure out where the problem is… right now we suspect this is on the server side. I’ll let you know more as soon as our developer has had a chance to investigate.


#12

I am also having a similar problem. Rpi3 is showing offline for 12 hours. Rebooted the device with no change. I can ping the Pi but have not done anything else.

Is this a server side problem after the update?

Thanks


#13

For the last 24 hours, I have seen that also my raspberry pi goes offline. After reboot it goes online again but after some time goes offline. I have changed the internet connection because I was thinking that there is a problem, but I think that is a server side problem.


#14

Hi guys,

I think it probably is something on our server side given the number of people who are reporting the same situation, I’ll let you know more as soon as our developer has had a chance to investigate.

Am I safe to assume that when your Pis are in this state, you can still SSH into them and they have internet connection (can ping a major website like www.google.com, etc)?


#15

@rsiegel Yes, I can SSH to the Pi as well as ping google.com from the device.


#16

@rsiegel Is there any logs i can look at to find out why my device keeps randomly disconnecting and reconnecting? During the times of disconnect i can always ping the device.


#17

We’re running into this on our side as well right now. I don’t think this is anything related to your specific device that you’ll be able to troubleshoot on your own. We’re going to have to figure out what’s going on our our server side to correct this issue.


#18

I’m having the same issue we a newly installed PI3 today. Was working fine this morning but now it just shows offline. I tried removing it from the dashboard and rerunning the install to no avail.


#19

Hi @jdfletchx7 and welcome to the Cayenne Community.

I came to say that we pushed a hotfix server side for this issue yesterday and see if other users in this thread saw an improvement, but it looks like we might have additional work to do if your behavior is the same thing.

Can you confirm that the Pi is otherwise online (outside the context of Cayenne)? In that it can access an external website or ping www.google.com, as a sanity check?


#20

Yes, I can reach external websites from the browser,