Device offline in cayenne


#21

Hi again @jdfletchx7,

Thanks for the additional info you sent via PM. Based on this part:

root@raspberrypi:/home/pi# service mydevices status ● mydevices.service Loaded: not-found (Reason: No such file or directory)

I don’t think you have the same issue that has been discussed in this thread. In those cases the myDevices service was present and running but the devices still showed in Cayenne as offline. In your case, the myDevices service doesn’t even seem to be present in the first place. I’m a little surprised it worked at all in the past!

That said, I think a simple uninstall and re-add of the Pi would be the easiest solution here to ensure that you have a fully valid install of the agent software as it looks like a piece is currently missing. If it continues after that we’ll have to look into why it’s disappearing, something I’ve not seen before.

Here is how to uninstall/re-add (assuming you aren’t super attached to anything on your Pi dashboard in Cayenne at this point.) If you want to keep your dashboard I can give you different steps to re-use the same invite code.

  1. Uninstall the Cayenne Pi agent using the following two commands:

sudo /etc/myDevices/uninstall/./uninstall.sh
then
sudo /etc/webiopi/uninstall/./uninstall.sh

  1. Next, you can attempt a new installation. Please do this from the Web Dashboard and select Option 2 where it shows two commands to install the software on your pi. Once the install is complete, the Pi will reboot and then should show online again on the web dashboard. If the install stops with any errors please let me know what they are.

After that reboot, service myDevices status should look more like this where it shows ‘active’:

If it ever starts showing as ‘offline’ to you when the Pi otherwise seems online, then run that command and let me know if its showing as ‘not-found’ again.


#22

@riegosg @aicraga @walters

As mentioned in my earlier post, we made a hotfix yesterday which we believe resolved your original issue with Raspberry Pi’s showing as offline in Cayenne while they were otherwise internet connected as you’ve described.

When you have a moment could you check your Pis and see if they are showing the proper and expected status in the Cayenne dashboard, and let me know if you’re continuing to see this behavior where Cayenne reports them offline when they really aren’t?


#23

Hi !

Thanks for your answer. Right now is everything ok with my dashboard, lets wait a few days to see if it is really stable.

Kind regards.


#25

I’m having a very similar issue. Neither of my pi’s will show to be online on neither the online dashboard nor the app. After rebooting the Pi it doesn’t become online but the dashboard said “Last known status 1 min ago” which was the time of reboot. I’m running the 4.4 Kernel.


#26

@julian could you post the output from service myDevices status on the problem Pi(s)?


#27

I have even problem , scren


#28

Hi @julian @falvojeanremi,

I saw this again this morning as well on 2 of my Pis. We’ve made another adjustment to the server and it looks like things are behaving again. Let me know if it is for you as well. My apologies for this intermittent downtime, the problem was again on our server side and not related to any status of the software on your Pi(s).


#29

My arduino were going on and offline a lot. Would that along the same lines of this trouble? Usually have to reset them couple times but sometimes they just go back online


#30

yes, that is almost certainly the same issue. Our Raspberry Pi and Arduino devices talk to the same server, which is different from where MQTT/LoRa ones go. So assuming your Arduinos weren’t connected via MQTT I think that’s the answer.


ESP8266-1 not connecting to dashboard
#31

It works again. Thanks for looking into it!


#32

Great news, thanks for letting us know. I’m going to tentatively move this thread to the ‘Helped’ category, but by all means let me know if you (any of you) start seeing this again.


#33

HI Rsiegel,
Without making any changes my Pi is connected.


#34

I was having this issue up until this afternoon. The hotfix resolved the majority of my issues, but my digital output for an LED has not recovered. After a few seconds (or whenever I refresh the webpage) it goes into an ‘Unreachable’ status. I attempted to remove and re-add the button but the same result.

I did verify that I had the correct GPIO listed

My temperature sensor remains functional the entire time, even throughout this issue.

Upon this offline issue last night, I followed the troubleshooting steps outlined here: Troubleshooting Pi Showing Up as Offline in Dashboard and wound up changing a few things recommended.
-My Network.ini file was missing the “SARSServer=reg.mydevices.com” & “RemoteDesktopServerAddress=rds.vcom.com” lines so I added them
-My AppSettings.ini file did not have an ID listed, so I added mine as instructed.

I used the code here ( https://www.raspberrypi.org/forums/viewtopic.php?f=32&t=41639&p=377649&hilit=%2Btkinter#p377649 ) and was able to easily verify that the LED does in fact work without issue.

Any ideas?


#35

An update for the thread (and for you specifically @mechbuster2)

It looks like we haven’t quite squashed this issue server side, but we’ll be making another hotfix today that our engineers have good confidence in. A moment ago it was happening again to my Pis, and while things are OK at the moment that I type this, until the hotifx is out (hopefully a matter of minutes or hours now), it’s possible it could recur again. So if you’re still seeing the offline/zero value widgets issue, hang tight for my update before retesting.

@mechbuster2,

For your issue of the ‘Unreachable’ button, I suspect it is probably related to this and should wait for the hotfix for a retest. But in the meantime, could you post the output from uname -a on that Pi to ensure that you’re not running into another issue I know can cause an unreachable button?

Also, that post about troubleshooting Pi offline is a bit out of date. I don’t think there is any harm to the changes you made regarding SARSServer/remote desktop/AppSettings.ini but those things are not necessary in the current build of the Pi agent software. I’ll edit that FAQ post to bring it up to date in just a moment.


#36

could you post the output from uname -a on that Pi to ensure that you’re not running into another issue I know can cause an unreachable button?

Sure thing! The output I get is;

Linux raspberrypi-tank 4.9.35+ #1014 Fri Jun 30 14:34:49 BST 2017 armv6l GNU/Linux

Also, that post about troubleshooting Pi offline is a bit out of date.

Ok good to know. Some of the output wasn’t right but I figured it couldn’t hurt to make those changes.

I’ll wait until tomorrow and see if there are any changes. Thanks for the rapid response @rsiegel


#37

Ah, ok, so (and apologies for these issues) this one is because you’re running the 4.9 Linux kernel. There is a component of our software that only behaves with the 4.4 kernel that is part of stock Raspbian Jessie at the moment.

This can be resolved by switching to the 4.4 kernel with the following command:

sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

and then rebooting the Pi when it’s done.

That should solve the Unreachable button issue for you. We have an agent update in QA at the moment that will work with both 4.4 and 4.9, putting an end to this issue, and should be released as an automatic update as soon as our QA signs off on it.


#38

All, the latest hotfix is in place – when you have a chance again, check your devices, and the real test will be stability over the course of days and weeks, so let me know if you suspect this offline Pi issue again in the future.

Thanks for your patience while we work out these kinks in the server!


#39

@rsiegel downgrading to 4.4 fixed the issue!

I will check it when I get back from travel in August. Where is a good place to see if the agent update has been signed off on?


#40

My PLduino is mega based and it’s the only one now with the online/offline problem. It uses wifi thru esp-02. Any suggestions?


#41

Hi all!

Cayenne is stucked again:

“Last known status: 7 hours ago (Jul 9, 2017, 2:40 am)”

but I’m using 4.4 kernel, so the problem looks to be worst:

“Linux raspberrypi 4.4.48-v7+ #964 SMP Mon Feb 13 16:57:51 GMT 2017 armv7l GNU/Linux”

After reboot Cayenne status is the same, stays down.

Guys, please remember J.F.K. words:

“We choose to fix Cayenne problems in this decade, not because it is easy, but because it is hard”" :wink:

Good luck and good work!