Raspberry Pi shows as offline intermittently

Hi - over the past few weeks I’ve started to have problems with my RPi (Raspbian 4.4) showing offline in the dashboard from time to time. Sometimes cycling the power will get it to show up again, other times it’s just a case of waiting… I’m aware there are some reports of server-side issues that might be causing this - this would fit the scenario I’m seeing (have tried with two separate RPis, different OS versions etc - but get the same issues).

Does this (server issues) sound like the likely cause? If so, is there any update on a resolution? And are there any recommended workarounds for getting an offline device to be recognised again? My RPi controls my aquaponics system and a remote fish feeder - and the fish are starting to get hungry!!

Thanks for any steers on this.

I got two Pi3 with RPi (Raspbian 4.4), downgraded from 4.9. One is working almost fine, but the other is unstable, and I can not add widgets to it.

I moved the SD card from the pi3 that was working to the one that was not working right, and then it too was working just fine, so the problem is inthe software on the pi3. In the dasboard it shows: OS: respbian 8 (debian), and now I can see and control all the GPOI pins and also remote access is working fine. I will copy the SD card that is working, and see if I can make both pi3 work at the same time.

Before I copy over the SD card. Is there some files I should make a copy of? Something Cayenne will need to identyfy the second Pi3?


Make sure to do a re-install of the Cayenne software if you do this, as it identifies each Pi with an invite code and a device ID that is unique to each installation. If you copy the install from one Pi to multiple others, Cayenne may get confused between the device entries. All you need to do to re-install is to run the following two commands to uninstall, then re-install from Add New > Device / Widget > Single Board Computers > Raspberry Pi.

sudo /etc/myDevices/uninstall/./uninstall.sh
sudo /etc/webiopi/uninstall/./uninstall.sh


I apologize for the intermittent offline status you’ve been seeing. While it could be something local to the Pi, right now my suspicion is that this is related to the server issues you’ve been reading about. Unless you’re noticing they both have this issue at the same time, in which case it would be worth investigating your local network. (really, the only thing to check is: do your Pis have an stable internet connection anywhere else when Cayenne says they are ‘offline’? If they do, and they’ve been online on that network in Cayenne in the past, it’s almost certainly the server issues we’ve been aware of.)

This is the first item on our list as soon as we can recover some development resources from the team working on the new IoT in a Box solutions. We’re a small company and those are helping us keep the lights on for free projects like Cayenne, so thank you for your patience. I definitely would not want any fish to be harmed do to our delays, so if you have anything mission critical please consider making an offline fallback for it (or online outside of Cayenne).


Having same issue. Switched to 4.4 and it improved, but still not usable.

Thanks for letting us know. Ultimately online/offline is a server side issue that we’ll have to tackle, and not related to the Linux kernel issue where the 4.9 kernel breaks compatibility with the software we use to interface with the Raspberry Pi GPIO.

What is the latest on Raspberry Pi 3 kernel and also the camera? I have been putting my project on hold for one year waithing for Cayenne updates on this.

sorry for the inconvenience caused. @adam @eptak tagging for this.

Thank you for answering. I can live with the delay of the camera widget. I can work around it with commands, so it is not so critical. What kernal will you recomand? I have downgraded to kernal 4.4 and it is working, but I am not sure if that is the best uption awailable at this time.

have a look at this Dashboard unresponsive lag - raspberry pi [Solved: Kernel Issue] - #5 by rsiegel

1 Like