DS18B20 Temperature Trigger Slider

I am using three DS18B20 Temperature sensors in my project to monitor and control the temperature of aquariums. When I set up a trigger to turn on or turn off a heater based on the temperature reading, the range on one of the sensors has a very limited range (71 - 72.5 F). On the other two sensors the range is automatically -67 - 257 F. If I try to change the upper limit it will accept the edit but after it is saved it reverts back to 72.5. I have deleted the trigger and and set it up again but still a max of 72.5 F. I have refreshed all of the pages and the maximum doesn’t change. I have logged out and back in and still the same. If I use my iPhone to set the max it will accept the change, but it still shows 72.5 F in the webpage from the PC.

  • Device & model you are using Pi 2 Model B

  • What dashboard are you using? Web,and iOS (10.2)

Hi @wbarsuhn, welcome to the Cayenne Community.

I think you’re onto a legit bug here. I set up a similar Pi to what you’ve described here, and while I’m not seeing one of the trigger ranges stuck between such limited values of 71-72.5, I’m not able to get any of my DS18B20 triggers to retain a change to the Min/Max setting, which is ultimately your problem here.

I don’t want to make things worse for you, but do you mind confirming by taking one of your triggers that has the full range, and editing it slightly? For example, changing one with a range of -67 thru 257 to -66 thru 256, then saving. I’d be interested if those values are retained for you when checking after saving.

Actually another question now that I think of it:

For the slider you have stuck between 71 and 72.5, presumably you want to set the temp somewhere outside of it. If you change the upper and lower limits to a much wider range, and then set the temp slider to something outside of your limited range, what value does the slider itself return to when you re-view the trigger and the min/max values go back to 71/72.5?

For example, if you made the range 0 to 100, and set the slider to 15F, does it lose the 15F setting (as well as the min/max values) when you view it after saving?

I just tried this and it would not accept the change.

It didn’t retain the change? Or didn’t even let you use the Save button?

I changed the range (0 - 100) and hit save, when I opened the page again it was back where it was before (71 - 72.5).

I tried this change with two of the three temperature sensors that I am using and after saving the changes when I re-opened the page the values were back to the previous settings.

Thanks, I appreciate you double checking for me, that’s what I expected.

While we work on the bug that the min/max ranges aren’t retained at all, I’m hoping we can get that third DS18B20 to show you the default range, which hopefully is good enough for you to make your third trigger. Here is what I would try (this is assuming that all of your DS18B20s are connected to GPIO 4 on your Pi, which is able to detect 1-Wire sensors and allows Cayenne to auto-create widgets for them):

  1. Remove the DS18B20 sensor which is giving you this trouble by clicking on it’s gear icon > Settings > Remove. This should delete the associated trigger entry as well.

  2. Reboot off the Pi via the reboot command on the Cayenne dashboard (or via the Pi itself if you prefer).

  3. On reboot once the Pi is back online, Cayenne should re-detect your missing DS18B20 sensor and create a new widget for it. This may take a minute or two after it comes back online.

I can’t promise that the new widget won’t have the same issue with regard to trigger range, but its worth a shot.

Hi @wbarsuhn,

This should be fixed now. Let us know otherwise? Thanks!