FAQ's

Hi All,

I just became a member of this great website.
I have an issue whenever I try to add new switch to my device. There is no any icon in the list!
Any idea ? Is this web browser problem. On my phone it is working well.

@marton.szoke welcome to the Cayenne community! Hope to keep seeing you around.

What browser are you using? Can you try first selecting a Pin in the above dropdown too?

-B

I tried under firefox and chrome too … same results.
Here is a new pic. of chrome selected pin . The drop down menu still does not work.

I just downloaded the latest Arduino IDE (Ver. 1.8.0).

Questions:

Do the ESP12-e chips still prefer the “Generic 8266” board choice, or is the NodeMCU board a better choice?

(I suppose I could just dive in and start flashing
and find out myself, but I’m not set-up right now)

I see that after the latest Arduino IDE installation, I still have the Cayenne library installed- Is there anything else I may need to know re: Esp12-e/ESP8266?

The reason I ask- because of the un-availability of GPIO 14 and 16 (previously, you had to write/read to a virtual GPIO pin, then add code to the Cayenne simple framework on the Arduino IDE ESP device flash). I’d hate to design the GPIO expander chip in my PC boards, -but I’ve gotta have more GPIOs. Wishing I had 6 GPIO rather than the 4 usable GPIO (4, 5, 12, 13).

I’m TOLD (never observed) that GPIO 16 has a pull-down resistor, while all other GPIOs have software programmable pull-ups. does anyone know for sure? I get conflicting info on the internet.

I tried designing a PC board using GPIO 2 and GPIO 0, using 1 shot delays.
Bottom line-
WARNING: do NOT try to use GPIO 0 and GPIO 2! Even if you pull the lines high, -just…don’t use GPIO 0 and GPIO 2!

GPIO 0 is used, of course, to enter FLASH programming mode.
GPIO 2 is used to address SD card memory.

Even if you tie GPIO 2 high, it’s connected to the blue LED/1.8K current limiting resistor to 3v3.

It’s best to program GPIO 2 as a generic digital OUTPUT,
I label this as “Blue LED”.

So- is Esp12-e GPIO 14 and 16 now “easily” addressable? Thanks!

This might have been fixed already but it’s working for me. Are you still having this issue?

Virtual pins are currently the only way. Is there a reason you don’t want to use them until the ESP is supported?

-because I’m a horribly crummy, uneducated simpleton who needs the code literally pasted in front of me.

Sorry Adam , I still have same issue , no drop down list of choose icon does not work.

hi @bestes i have raspberry pi 3 model B and i cannot remote access "Desktop not responding
can you help me to solve this issue

1 Like

Guys, BT is more than important it is mandatory to have, Please help the huge number of devs that are waiting for be able to use Cayenne !!! Tks

1 Like