Raspberry pi first time installation problem of cayenne application

I am using Raspberrypi model B.

I am doing SSH in the PI with my laptop. the problem is I am not able to install the app by command lines proveided. Also the application is not suppoeted by my phone sumsung galaxy grand quatrro.

I’m seeing “Invite code does not exist”, that can either mean you have the invite code typed in incorrectly, or maybe the null invite code bug has changed a bit? I also see that you are using Ubuntu. Are you using Ubuntu on the Pi or is that another computer you are using to run the commands with SSH?

It sounds like he is SSHed into the pi from a laptop, but I would be interested in the results from cat /etc/os-release on the Pi regardless just in case.

What this looks like to me is that there was a previous install (whether full or partial), or at very least a folder already at /etc/myDevices which is why the script thinks there is a previous install and then goes searching that .ini file for an invite code that it can’t find.

I’d try running these two uninstall commands (they may throw errors if the uninstall scripts aren’t in place, but it can’t hurt to attempt them):

sudo /etc/myDevices/uninstall/./uninstall.sh
sudo /etc/webiopi/uninstall/./uninstall.sh

Then regardless of their output, I’d check to make sure the /etc/myDevices and /etc/webiopi folders are not present on your Pi, and if they are still, delete them with rm. If you need steps to do this let me know.

After you’ve confirmed those folders and their contents are gone, I’d try the sudo bash command on that same installer .sh file again and see if the install proceeds ok. If it doesn’t, share the output and we’ll continue to help troubleshoot.

1 Like

Oh and with regard to your Samsung Galaxy Grand Quattro phone, what version of Android OS does it run? The Cayenne app should behave on anything with Android 4.4 or newer.

Selective reading strikes again…

:grin: SSH is a perfectly cromulent verb

I just meant that he put in his post that he was SSHed (definitely a verb) and I ignored it haha


I have done the steps shown above also I am connecting PI with ethernet cable to my Laptop and do ssh

Thanks for the new screenshot. Looks like the OS is good. To remove that /etc/myDevices directory try:

rm -rf /etc/myDevices/

Then give the installer another shot, and show the output if it doesn’t complete successfully.

the command to remove directory works well. after that the first command runs well but the second command gives an error!! please see the screenshoot. also, the connection gets reset(during second command) by the pi which might create such problems…

I’m sorry, I’m missing the error in the above screenshot. Can you point it out for me?

This is the problem when I run the second command

Is the ssh has problem of disconnection??
Anyone has experienced that?
When I run second command only than it will disconnect
else it is ok

I can’t remember now if it actually says rebooting in the console before it does it, however, it will reboot automatically so that would be why it is disconnecting. Does it show up on the dashboard after the disconnect?

The pi agent installer does reboot at the end of install, but its well after the part that’s displayed here. You should still see a lot more text than this, there would be the rest of the myDevices agent installer and whole install of webiopi first. It’s literally the last item in installation.

This is making me think something else is going on causing PuTTY to disconnect like that. It’s also making me wonder if the install is actually plugging along OK even though you’re losing your SSH connection. If you login at Log in to Cayenne do you see the Pi on your dashboard, or is it still a pending device that is grey in the left sidebar?


Hmmm… Perhaps far fetched, but can you tell us what the amperage of your power supply is? Just wondering if system resources demanded by the script is causing a low wattage power supply to drop the voltage and thus causing reset.



Following are some images…
The power source is a charger pin. Output 5V 550mA.
Yes it is true that RED LED sometimes goes on-off, does it mean power supply problem?

When I login I see the first image which shows device was on 1 day ago!!

okey so the problem was power supply!!

1 Like

good catch @kreggly

1 Like