Help to determine cayenne is running as it should in the pi

My dashboard was working last night but shows off line this morning. The pi seems to be ok, able to access internet etc. cmd line working ok.

Does cayenne sdk runs a python script called by cron at regular interval? How do I find out that cayenne and all the dependencies are running ok in the pi. I suspect some cmd will show the status. I do not want to reboot yet, but find out if cayenne is running as it should in the pi now or could it be the cayenne server.

Welcome to Cayenne!

Can you try everything in this post and report back? Troubleshooting Pi Showing Up as Offline in Dashboard

pi@raspberrypi ~ $ sudo df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 7.2G 2.9G 4.1G 42% /
/dev/root 7.2G 2.9G 4.1G 42% /
devtmpfs 460M 0 460M 0% /dev
tmpfs 93M 312K 93M 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 186M 21M 166M 11% /run/shm
/dev/mmcblk0p1 56M 19M 37M 34% /boot

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
link/ether b8:27:eb:9e:5e:62 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether 74:da:38:41:7d:e2 brd ff:ff:ff:ff:ff:ff
inet brd scope global wlan0
valid_lft forever preferred_lft forever

Active Internet connections (servers and established)
tcp 0 0 ESTABLISHED 2723/chromium --pas
tcp 0 0 ESTABLISHED 2723/chromium --pas
tcp 0 0 ESTABLISHED 2723/chromium --pas
tcp 0 0 ESTABLISHED 2723/chromium --pas
tcp 0 0 ESTABLISHED 2723/chromium --pas
tcp 0 0 ESTABLISHED 26093/python3
tcp 0 0 ESTABLISHED 3291/http

As requested so far; also i have cay dash loaded on the pi

and still offline

sudo service myDevices status shows is running
network.ini shows as in the post

Looks like you have a connection to Cayenne established. Can you verify that your pi’s ID and the dashboard ID match up?

I am not sure how to do that;
bty when I type sudo netstat -natp | grep -1 establish:
tcp o o

It’s at the very bottom of the post I linked

Yes they do match.

@bestes looks like everything checks out, any ideas?

I tried opening dashboard using chrome on the pi where cayeene is install and still shows offline, does dashboard works on localmost?

Hi @kenkoknz,

Sorry you are experiencing this. Hope to get it resolved soon.

To clarify, have you tried accessing the Cayenne dashboard from a browser on a laptop or desktop? (Not from the Pi itself…)

Looks like you’re on the correct port (8181) so no issues there.

If you wouldn’t mind, can you Private Message your Cayenne account login credentials (username / password) so we can try and see if we’re able to identify any issues.


Thanks for helping @ats1080s

Hi @kenkoknz,

Any updates here?



Hi, thanks for followup, I am now thinking it could be something to do with my connection. I am using 3g modem, have to try a fix line maybe.