Installing Cayenne


#1

I get this message when trying to install cayenne. ERROR: The certificate of cayenne.mydevices.com' is not trusted. ERROR: The certificate ofcayenne.mydevices.com’ hasn’t got a known issuer.


#2

Hi @gbelectrical and welcome to the Cayenne community.

I’m confident at the moment that our certificate is OK, my first suspicion is that the time/date on your Pi where you’re seeing this error may not be set properly, which can cause cert validation errors. Raspberry Pis can be funny about time – they don’t have any built-in clock battery like a proper PC in order to cut costs on the board, so time/date come from an NTP time server at boot time. This can fail on occasion leaving the system time incorrect.

Could you run the command date on your Pi and let me know if it matches up with the real world time and date? If it doesn’t, I would suggest a reboot first, then running date again.


#3

HI

I checked the date and time and it is correct any other suggestions


#4

Hi @gbelectrical,

Apologies for the delay in my response, it was a holiday in the USA last week.

if you don’t mind, I’d be interested in the full output of the wget command when you run it and get this error, so I can see which IP it’s attempting to connect to on our side.

You can certainly bypass this check completely by including --no-check-certificate into your wget command ala:

wget --no-check-certificate https://cayenne.mydevices.com/dl/rpi_i3ha3545c0.sh


#5

hi RSiegel

i’ve got the same problem. i’m trying to installl cayenne from the terminal and even from mi IOS device.
one of then (IOS devide), the app do a match with the device and after try to install some some libraries. but after too much time the process still in the step 1 of 4.
on the other hand. terminal way. i attached the full sentences that i put

pi@raspberrypi ~ $ wget https://cayenne.mydevices.com/dl/rpi_lxxxxxxx0.sh--2017-08-25 19:40:59-- https://cayenne.mydevices.com/dl/rpi_lxxxxxxx0.sh
Resolving cayenne.mydevices.com (cayenne.mydevices.com)… 52.44.92.150, 52.7.52.140
Connecting to cayenne.mydevices.com (cayenne.mydevices.com)|52.44.92.150|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1295 (1.3K) [binary/octet-stream]
Saving to: `rpi_lxxxxxxx0.sh.3’

100%[======================================>] 1,295 --.-K/s in 0s

2017-08-25 19:41:11 (2.76 MB/s) - `rpi_lxxxxxxx0.sh.3’ saved [1295/1295]

pi@raspberrypi ~ $ sudo bash rpi_lxxxxxxx0.sh -v
rpi_lxxxxxxx0.sh
continuing as new install…
–2017-08-25 19:41:16-- https://updates.mydevices.com/raspberry/myDevices-1.0.tar.gz
Resolving updates.mydevices.com (updates.mydevices.com)… 54.148.225.117
Connecting to updates.mydevices.com (updates.mydevices.com)|54.148.225.117|:443… connected.
ERROR: The certificate of updates.mydevices.com' is not trusted. ERROR: The certificate ofupdates.mydevices.com’ hasn’t got a known issuer.

i have to say that i’m new in this and if you can help me with this, it will great. thanks


#6

There have been some reports that updating the OS or installing the newest version of Raspbian will fix this certificate error, but right now that’s not an option because of the 4.9 kernel bug. @rsiegel do you have any suggestions?


#7

@contrerasrommel, welcome to the Caynnee Community.

It looks like this is the same error as earlier in this thread, just with a different server. (updates.mydevices.com instead of cayenne.mydevices.com).

I’m still not 100% sure what causes it, but if you trust me that we have a perfectly valid certificate (you can verify by visiting https://updates.mydevices.com/ in your web browser, it will show a secure connection and valid certificate), then we can just work around this by skipping the certificate check here as well. To do this:

  1. Open your rpi_<INVITE_CODE>.sh script in a text editor of your choice

  2. Locate this line:
    wget -O $HOME/$PREFIX.tar.gz "https://updates.mydevices.com/raspberry/myDevices-1.0.tar.gz"
    and replace it with
    wget --no-check-certificate -O $HOME/$PREFIX.tar.gz "https://updates.mydevices.com/raspberry/myDevices-1.0.tar.gz"

  3. Save your changes and run the script again. It should now bypass the certificate check when contacting that updates.mydevices.com server and continue on with the installation process.

Let me know if you have any trouble or questions with the above.


Jessie on Orange Pi Plus 2
#8

downloads OK but see below:

./myDevices-1.0/3rd_party/requests.tar.gz
./myDevices-1.0/3rd_party/suds-jurko-0.6.tar.gz

  • set -x
  • exec
    (0%)
    Tue Oct 3 21:12:25 CEST 2017 Installing myDevices agent
    0
    Tue Oct 3 21:13:17 CEST 2017 Found Python 3.2.3…
    (50%)
    Tue Oct 3 21:13:17 CEST 2017 Copying agent libraries
    (55%)
    Tue Oct 3 21:13:20 CEST 2017 Installing python utils
    (60%)
    Tue Oct 3 21:13:49 CEST 2017 Installing software components
    Tue Oct 3 21:13:50 CEST 2017 Cannot install for Python 3.2.3 : missing development headers\n
    Tue Oct 3 21:13:50 CEST 2017 Finished agent code
    Tue Oct 3 21:13:50 CEST 2017 ERROR: myDevices cannot be installed - please check errors above


#9

Try these commands:

sudo apt-get update
sudo apt-get updgrade
sudo apt-get -f install
sudo apt-get install python3.4


#10

Let us know how @adam 's suggestions go for you. Hoping you get Cayenne up and running soon :slight_smile: